clicking links in mail (with alternate 3-pane) fails (NS_ERROR_XPC_BAD_CONVERT_JS)

VERIFIED DUPLICATE of bug 282938

Status

SeaMonkey
MailNews: Message Display
--
major
VERIFIED DUPLICATE of bug 282938
13 years ago
13 years ago

People

(Reporter: R.K.Aa., Assigned: (not reading, please use seth@sspitzer.org instead))

Tracking

({regression})

Trunk
regression
Bug Flags:
blocking1.8b -

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
2005021615 and yesterdays build

nothing visibly happens when clicking a link in a mail - left click or middle
click- whatever way i try to open a link in a mail will fail now.

This appears in JS console:
 Error: uncaught exception: [Exception... "Component returned failure code:
0x80570009 (NS_ERROR_XPC_BAD_CONVERT_JS) [nsIXPCComponents.lookupMethod]" 
nsresult: "0x80570009 (NS_ERROR_XPC_BAD_CONVERT_JS)"  location: "JS frame ::
chrome://global/content/XPCNativeWrapper.js :: anonymous :: line 91"  data: no]
(Reporter)

Comment 1

13 years ago
it still worked in Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b)
Gecko/20050115
(Reporter)

Updated

13 years ago
Flags: blocking1.8b?
(Reporter)

Updated

13 years ago
Summary: clicking links in mail fails → clicking links in mail fails (NS_ERROR_XPC_BAD_CONVERT_JS)
(Reporter)

Updated

13 years ago
Flags: blocking1.8b2?
Any chance of a narrower regression window?
Trunk Seamonkey Mail seems to be OK for me.
this seems to be working for me using 2005021706-trunk seamonkey bits on Windows
XPsp2.

some notes: I hadn't set mozilla mail or browser as the windows default apps for
those tasks, but it still seems to work for me. it also still worked whether or
not I had a mozilla browser window open. (I don't see the js error rkaa saw either.)
(Reporter)

Comment 5

13 years ago
also happens in a 20050202 build. see also bug 282593
Resolving as invalid since nobody else sees this bug.
My main changes in prefs from default is disabling "lookahead" and JS for
mailnews, in addition to some disabling for browser (these abilities are disabled:
move or resize existing windows, hide the stgatus bar, replace or hide context
menus)
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → INVALID
(Reporter)

Comment 6

13 years ago
This bug and bug 282593 happens to me when in alternate treepane (2+1)
The default treepane works fine.

sairuh: did you test that?
Status: RESOLVED → REOPENED
Resolution: INVALID → ---
Too late for 1.8b1, plussing for 1.8b2, assuming that it is reliably
reproducable with alternate 3-pane.
Flags: blocking1.8b?
Flags: blocking1.8b2?
Flags: blocking1.8b2+
Flags: blocking1.8b-
Yeah, I can reproduce with both alternate forms of the 3-pane.
Summary: clicking links in mail fails (NS_ERROR_XPC_BAD_CONVERT_JS) → clicking links in mail (with alternate 3-pane) fails (NS_ERROR_XPC_BAD_CONVERT_JS)
ah! yes, with that 3pane modification I do see this.

I'll see if I can repro on other platforms...
(Reporter)

Comment 10

13 years ago
Lowering severity a notch. But keeping it on related bug 282593 since I believe
that one can lead to dataloss.
Severity: critical → major
yep, also occurs on Mac mozilla trunk.
OS: Windows XP → All
Hardware: PC → All
Problem was easily re-created on 2/15 trunk-build(Win-2K) - link click with
alternate 3-pane.
I love alternate 3-pane but I always used "middle click" in order to open in new
Tab. ( using Tab Browser Extentions which is hated by Firefox developers... :-) )

R.K.Aa.: Does similar problem occur on other click operations on link?
 - Right click of the link
 - Click in context menu of the link
   - Open in new window etc. in context menu  
(Sorry but I can't say whether Mozilla's problem or not, because error message )
(when "Open in new windows" contains error message of "Tab Browser Extentions".)
This problem didn't occur on Thunderbird.
(tested with next 2 TB-trunk-nightlies, with no extention, no theme)
 /thunderbird/nightly/2005-02-04-08-trunk/thunderbird-win32.zip 
  version 0.6+ (20050204)
 /thunderbird/nightly/2005-02-19-05-trunk/thunderbird-win32.zip
  version 1.0+ (20050219)
(Reporter)

Comment 14

13 years ago
>R.K.Aa.: Does similar problem occur on other click operations on link?

Please read the bug report.

Adding suspects to CC.
(In reply to comment #14)
> >R.K.Aa.: Does similar problem occur on other click operations on link?
> Please read the bug report.
Oh, sorry. You said "middle click" also has problem.
(my "middle click" was probably hooked by extention.)
But my question is on "Left Click in context menu".
0001: aPropName
$[0] = [string] "location"
0001: this.mUntrustedObject
$[1] = [null] null

called from:
     68 function getContentFrameURI(aFocusedWindow)
in contentAreaUtils.js

0001: isContentFrame(aFocusedWindow)
$[3] = [boolean] false

window.content is null.
Depends on: 282877
(Reporter)

Comment 17

13 years ago
https://bugzilla.mozilla.org/show_bug.cgi?id=282877#c7

*** This bug has been marked as a duplicate of 282938 ***
Status: REOPENED → RESOLVED
Last Resolved: 13 years ago13 years ago
Resolution: --- → DUPLICATE
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.