Searching the mail body locates the text also in the encoded attachements

RESOLVED DUPLICATE of bug 136055

Status

Thunderbird
General
RESOLVED DUPLICATE of bug 136055
13 years ago
13 years ago

People

(Reporter: Tomasz Lisowski, Assigned: Scott MacGregor)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; pl-PL; rv:1.7.5) Gecko/20041108 Firefox/1.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; pl-PL; rv:1.7.5) Gecko/20041108 Firefox/1.0

The message search function (Ctrl-Shift-F) with the Body(Contents) as the
criterium locates the given text also in multi-part messages in MIME format with
the encoded attachements (e.g. base64-encoded MS Word file) within the
attachement part of the message, which is a garbage (as far as humans are
concerned :-) and should not be searched.

Reproducible: Always

Steps to Reproduce:
1. Find any message with an attachement. View its source. Make a note of any
character sequence within the attachement part of the message
2. Edit - Find - Search messages
3. Set the Body criterium, and search for the text fragment found in step 1
Actual Results:  
Among the search results, you will find this message, that contains this
fragment within the attachement part, and not within the header or the normal,
human-readable part of the message

Expected Results:  
This message should not be listed among the search results. The message Body
searching should search only the header and the part with the message text,
skipping the parts being the encoded attachments, as this makes no sense to the
user, and unnecessarily returns more matching messages, than it should be.

Comment 1

13 years ago
Search & filtering are core functionality. Please search always before for
existing bugs and include product "Core".

*** This bug has been marked as a duplicate of 136055 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.