Real Player plugin install page shows next button too early

RESOLVED FIXED in mozilla1.8final

Status

Toolkit Graveyard
Plugin Finder Service
RESOLVED FIXED
13 years ago
3 years ago

People

(Reporter: jblades, Assigned: Doron Rosenberg (IBM))

Tracking

unspecified
mozilla1.8final
x86
Windows XP

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.7.5) Gecko/20041110 Firefox/1.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.7.5) Gecko/20041110 Firefox/1.0

When downloading a Real Player plugin - haven't tried any other plugins - it
shows the "next" button whilst still downloading and before it even installs.
Pressing it takes you to a completed page giving the impression that it has been
a successful install and that Firefox needs to be restarted.

Reproducible: Always

Steps to Reproduce:
1.Click the download plugin link
2.Click the next button
3.Click the next button
Actual Results:  
As in the details - if you continue to do this, you will never install or even
download the plugin

Expected Results:  
Displayed a greyed out/unavailable button until the install had completed

As far as I'm aware there have been no changes made to the original Firefox install
Summary: Real Plyer plugin install page shows next button too early → Real Player plugin install page shows next button too early
(Reporter)

Comment 1

13 years ago
Upon installing the plugin - after not pressing the next button, Real Player
works, but even restarting FireFox does not allow me to play the video. I can
download and play, but the browser still insists that the plugin is missing. I
have tried this twice to no avail.
(Assignee)

Comment 2

13 years ago
accepting, good catch.

Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
(Assignee)

Comment 3

13 years ago
Targetting 1.1
Target Milestone: --- → Firefox1.1
(Assignee)

Comment 4

13 years ago
Created attachment 175056 [details] [diff] [review]
Correctly set advacenment to false if no licenses found.

The problem was that if no licenses were required, we set the next button to
visible (canAdvance(true)).  This fixes it.
Attachment #175056 - Flags: superreview?(mconnor)
Comment on attachment 175056 [details] [diff] [review]
Correctly set advacenment to false if no licenses found.

r=mconnor@steelgryphon.com
Attachment #175056 - Flags: superreview?(mconnor) → review+
(Assignee)

Comment 6

13 years ago
checked in.
Status: ASSIGNED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → FIXED
*** Bug 288386 has been marked as a duplicate of this bug. ***
*** Bug 277527 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 9

13 years ago
*** Bug 290265 has been marked as a duplicate of this bug. ***
Product: Firefox → Toolkit
Product: Toolkit → Toolkit Graveyard
You need to log in before you can comment on or make changes to this bug.