Crashes / hangs when the html table have thousands of rows.

RESOLVED WORKSFORME

Status

()

Firefox
General
--
critical
RESOLVED WORKSFORME
13 years ago
11 years ago

People

(Reporter: San, Assigned: Blake Ross)

Tracking

({perf})

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [needinfo-w11])

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; rv:1.7.3) Gecko/20041001 Firefox/0.10.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; rv:1.7.3) Gecko/20041001 Firefox/0.10.1

I pull up thousands of database records using browser. While IE brings them fast
and without any issue, Fire Fox has the following issues. 1) Often takes much
more time but renders the webpage 2) Some times it hangs and freezes 3) When 
very large it just crashes.

Reproducible: Always

Steps to Reproduce:
1.Spit out the necessary html for 10,000 records with say 10 columns in each row.
2.This is my java code.
3.	pw.println("<html><head><title>SQL Service</title></head>");
	pw.println("<body BGCOLOR=#FFFFFF><FONT FACE=\"Helvetica\">");
	pw.println("<h1><font color=#DB1261 face=\"HELVETICA\">");
	pw.println("SQL Service</font></h1>");
	pw.println("<FORM METHOD=\"POST\" sql=\"./SQLServlet\">");
	pw.println("<TABLE bgcolor=#EEEEEE cellpadding=2 border=0 align=center>");
	pw.println("<TR><TD colspan=2>SQL Service: <font color=#0000ff
face=\"HELVETICA\">Type in your sql.Only supports SELECT
statements.</font></TD></TR>");
	pw.println("<TR><TD colspan=2>&nbsp;</TD></TR>");
	pw.println("<TR><TD>Client (DB Schema) :</TD>");
	pw.println("<TD><select name=sourcecd>");
	Iterator iterator = (getSourceCodeList(pw)).iterator();
	int i = 0;
	while (iterator.hasNext())	{
		tempData data = (tempData) iterator.next();
		String outStr = "<option value=" + data.getSourceCd();
		if (data.getSourceCd().equals((String)sourceCode))	{
			outStr+=" selected";
		} else	if (i == 0 && sourceCode.equals("")){
				outStr += " selected";
				}
		outStr += ">" + data.getOrgUnitName();
		pw.println(outStr);
		i++;
	}
	if(sourceCode.equals("ALL")){
		pw.println("<option value=ALL selected>All");
	}
	else{
		pw.println("<option value=ALL>All");
	}
	pw.println("</select></TD></TR>");
	pw.println("<TR><TD colspan=2>&nbsp;</TD>");
	pw.println("<TR><TD colspan=2> <font color=#0000ff face=\"HELVETICA\">Note: Do
not select 'ALL' for tables in COMMON schema. This will return duplicate
records.</font> </TD>");
	pw.println("<TR><TD colspan=2>&nbsp;</TD>");
	pw.println("<TR><TD>SQL </TD>");
	pw.println("<TD><textarea name=\"sql\" cols=\"60\"
rows=\"15\">"+sql+"</textarea></TD></TR>");
	pw.println("<TR><TD colspan=2 align=center>");
	pw.println("<INPUT TYPE=\"submit\" VALUE=\"submit sql\"></TD></TR>");
	pw.println("</TABLE></FORM></FONT></BODY></HTML>");

Actual Results:  
Depending on the size of the data the performance could change as listed above.
1) Often takes much more time but renders the webpage 
2) Some times it hangs and freezes 
3) When  very large it just crashes.

Comment 1

13 years ago
Does the crash occur in a current trunk build?
http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/latest-trunk/
http://ftp.mozilla.org/pub/mozilla.org/mozilla/nightly/latest-trunk/

Comment 2

13 years ago
San, please test a recent trunk build.  The information you gave is not
enough for us to reproduce the problem.
http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/latest-trunk/
http://ftp.mozilla.org/pub/mozilla.org/mozilla/nightly/latest-trunk/
Whiteboard: [needinfo-w11]

Comment 3

13 years ago
Ok this is where i should have posted it....
I have a problem in loading a webpage with a big table.

Why i got to this bug is i was doing a search and while there were a few results
everything worked fine but when the page has 750 hit's it just doesn't work not
even after 4 hours of processing time.

this is the big query WARNING pc will become unresponsive ;) it is also a lot of
data more then 1.5 mb.
http://www.motorcycle-data.com/DBM/_html/liste_reifen_direkt.php4?rabatt=&zahlungsart=&querysav=&groesse=&profil=&hersteller=&gruppe=&motorradid=&besucher_id=nBm6ATDWwANW84NC&action=nologin&loginname=&passwd=&suchmode=&eurokurs=1.95583&nngebuehr=8.9&vkgebuehr=8&versand=8.9&zahlart=&bemerkung=&firma=&name=&land=&plz=&ort=&strasse=&email=&telefon=&suchmode=direkt&groesse=16&hersteller=%25&profil=&gruppe=%25
opera and ie work fine btw with this link
a query with 97 hits .... still slow compared ie and opera but bareable 
http://www.motorcycle-data.com/DBM/_html/liste_reifen_direkt.php4?rabatt=&zahlungsart=&querysav=&groesse=&profil=&hersteller=&gruppe=&motorradid=&besucher_id=nBm6ATDWwANW84NC&action=nologin&loginname=&passwd=&suchmode=&eurokurs=1.95583&nngebuehr=8.9&vkgebuehr=8&versand=8.9&zahlart=&bemerkung=&firma=&name=&land=&plz=&ort=&strasse=&email=&telefon=&suchmode=direkt&groesse=16&hersteller=BRIDGESTONE&profil=&gruppe=%25

a different search from the same place with just a few hits (19) same speed
opera ie and firefox so no problems here and i hope this tells me it is not the
website that gives me the problem but firefox is.
http://www.motorcycle-data.com/DBM/_html/liste_reifen_direkt.php4?rabatt=&zahlungsart=&querysav=&groesse=&profil=&hersteller=&gruppe=&motorradid=&besucher_id=nBm6ATDWwANW84NC&action=nologin&loginname=&passwd=&suchmode=&eurokurs=1.95583&nngebuehr=8.9&vkgebuehr=8&versand=8.9&zahlart=&bemerkung=&firma=&name=&land=&plz=&ort=&strasse=&email=&telefon=&suchmode=direkt&groesse=130+16&hersteller=BRIDGESTONE&profil=&gruppe=21

I hope someone can do something about it since firefox just doesn't load the big
one and it is the best "copy paste", to openoffice. Compared to the other 2 that is.

p.s. I am running xpsp2 and firefox 1.0.6

Comment 4

12 years ago
This seems to be related to the problem I am having with the following web page.

http://south.maine207.org/staff.asp

Using Firefox 1.0.7 - Page displays the list to about the R's

Using Firefox 1.5 Beta 2 - Page displays all entries, but the font changes to a
smaller font at about the same point, but the data is displayed.

Comment 5

12 years ago
OK i tested 1.5 beta 2 and actually loads the list of 761 entries. Although it
is still way slower then opera or ie but it works now (takes a couple of minutes
to load the page now)
I am loading a page with 1689 as for how long it takes.... long..... and seems
not to finish still...... but there is progress since the 761 entries loaded

Comment 6

11 years ago
San (msankar_us@yahoo.com) do you still see crash?

FF seems to have a perf problem, but I don't see a crash.

but WFM, approx same time, on IE and SM for Wouter's links. loading is only a few seconds if page is saved on PC and loaded from PC.  signficant delay is in the generation of the page at the source webserver.
SM - Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20060812 SeaMonkey/1.5a



Charles' comment #4
> seems to be related ...
> http://south.maine207.org/staff.asp
> Using Firefox 1.0.7 - Page displays the list to about the R's
> Using Firefox 1.5 Beta 2 - Page displays all entries, but the font changes to a
> smaller font at about the same point, but the data is displayed.

WFM 
http://webpages.maine207.org/south/departments/administration/southstafflisting.html

Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Keywords: perf
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.