arduere.online.pt - popup not blocked

RESOLVED WORKSFORME

Status

()

--
minor
RESOLVED WORKSFORME
14 years ago
14 years ago

People

(Reporter: higuita, Assigned: bugzilla)

Tracking

1.0 Branch
x86
Windows ME
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Win 9x 4.90; en-US; rv:1.7.5) Gecko/20041109 Firefox/1.0 (MOOX M2)
Build Identifier: Mozilla/5.0 (Windows; U; Win 9x 4.90; en-US; rv:1.7.5) Gecko/20041109 Firefox/1.0 (MOOX M2)

entering this site will open one new browser window with pub, i have enable the
popup blocking



Reproducible: Always

Steps to Reproduce:
1.enter http://www.arduere.online.pt/index.php?option=content&task=view&id=122 url
2. a new windows will open with pub, old window opens the url




Expected Results:  
no pop up

Comment 1

14 years ago
I dont get any popup, also tried disabling the popup blocker. Reloaded page at
least 10 times.

Comment 2

14 years ago
I also don't get one
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8b) Gecko/20050208
(Reporter)

Comment 3

14 years ago
humm...

tested again with a linux machine and didnt work...

the top frame with the ad was the "possible popup" that i got earlier

i will test in a few hours again in the windows version and if it still gives a
popup i will install the plain firefox instead of MOOX version

thanks
(Reporter)

Comment 4

14 years ago
i can confirm, in windows ME and firefox 1.0 (the mozilla.org one: Mozilla/5.0
(Windows; U; Win 9x 4.90; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0) i get a
popup...

i must add one thing, the popup show up only when i open the link in a new tab,
just click on the link will not open the popup, open in new windows will not
open the popup

also, this seens like a window version bug only, in linux i didnt got any popup

Comment 5

14 years ago
I get no popup windows from this site under any circumstances in my post-1.0
trunk build, but it is some very funky HTML. There were some window targeting
bugs in Firefox 1.0 that have since been fixed. Reporter, you say you see the
popup only when opening the given URL in a new tab. Does it matter what website
is loaded in the opening tab? (I suspect it does.) For example, do you see the
problem opening the link in a new tab from this bug report?

> the top frame with the ad was the "possible popup" that i got earlier

Yes that makes sense. This site's HTML goes something like this:
<html><head><script>
  document.write("<frameset>")
  document.write("<frame name='top'>")
  // etc
</script>
<frame src="xxx">
  <!-- etc -->
</frameset>

where "xxx" is another HTML document that itself contains script like this:

window.open(<url>, "top")

First, I've never seen a page that bootstrapped a frameset into being the way
this one does. I guess it works. Second, the attempt to open a window into the
frame named "top" should be allowed even during page load. Indeed it opens into
the correct frame in my build but it's possible that Firefox 1.0 had problems
with it.

So. The website doesn't appear to be random; it should behave the same every
time. It should also behave the same on all platforms. However its exact
behaviour may depend on the page you loaded it from. Please try to pin down
conditions for replicating the problem. In any case I suspect this is no longer
an issue in current nightly builds.
(Reporter)

Comment 6

14 years ago
>For example, do you see the problem opening the link in a new tab from this bug
report?

yes, it will open the popup all the time, also, from google, it also opens the
popup... i dont know any more places that point to this url 8)

>So. The website doesn't appear to be random; it should behave the same every 
>time. It should also behave the same on all platforms.

yep, now it also show the popup in linux, firefox 1.0 from mozilla.org
maybe yesterday i had some window open from that site already?
or maybe its related with the speed of the computers?
both computers are P3 in the 500-700Mhz range, so maybe the page is loaded in a
different place when the script is run

i will try in a more powerfull machine...

i'm downloading the latest nightly to give it a test also
(Reporter)

Comment 7

14 years ago
ok, on a fast machine the popup still show up...

but i upgrade to the latest nightly (Mozilla/5.0 (Windows; U; Windows NT 5.1;
en-US; rv:1.8b2) Gecko/20050223 Firefox/1.0+) and after several tries it didnt
open any popup, and only one showed the "popup blocked warning

so is probably what DanM said, a window targeting bug already fixed...

should i close this bug? if yes, what resolution? workforme? fixed?

Comment 8

14 years ago
I found another location with an unblocked popup:

http://wi.essortment.com/foodsoilhumus_rfdg.htm


it only appeared the first time I visited the URL though.

my browser version:
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5) Gecko/20050207 Firefox/1.0

Comment 9

14 years ago
I also encountered a popup that was not blocked at this site:

http://www.openofice.org/

Should I open a new bug report? I thought there was a bug report serving as a
'catch all' for popups not being blocked.  Does this bug report exist or am I
mistaken?

Peace...

Comment 10

14 years ago
(In reply to comment #7)
> but i upgrade to the latest nightly (Mozilla/5.0 (Windows; U; Windows NT 5.1;
> en-US; rv:1.8b2) Gecko/20050223 Firefox/1.0+) and after several tries it didnt
> open any popup, and only one showed the "popup blocked warning
> 
> so is probably what DanM said, a window targeting bug already fixed...
> 
> should i close this bug? if yes, what resolution? workforme? fixed?

WFM. If you can reproduce it with a current trunk build feel free to reopen.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WORKSFORME
Summary: popup not blocked → arduere.online.pt - popup not blocked
Version: unspecified → 1.0 Branch
You need to log in before you can comment on or make changes to this bug.