Local image files not shown correctly

RESOLVED INVALID

Status

()

--
major
RESOLVED INVALID
14 years ago
14 years ago

People

(Reporter: RH, Assigned: bugs)

Tracking

1.0 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; de-DE; rv:1.7.5) Gecko/20041122 Firefox/1.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; de-DE; rv:1.7.5) Gecko/20041122 Firefox/1.0

If in a web page an image should be displayed using a local absolute windows
path (i.e.: <img src="F:\path-to-image\image.gif">), the image is not displayed.
Instead the title is shown, because image file seems not to be found. This
happens only with a full path. If path is specified relative (i.e.: <img
src="path\image.gif") the image image is shown properly.

Reproducible: Always

Steps to Reproduce:
1. define an absolute image path as explained in the details above
2. display the web page
3. image should ot be shown


Expected Results:  
image should be displayed properly like with a relative path given

Comment 1

14 years ago
dupe of Bug 187930?
(Reporter)

Comment 2

14 years ago
Seems not to be a duplicate of bug 187930!

I passed wrong information:
The path is already with correct slashes: "/" as suggested with bug 187930

So I pass <img src="F:/path-to-image/image.gif"> with correct slashes. I don't
use "\". This information in the origin message was wrong. Sorry for that.
The system used runs under windows XP.

The misbehaviour appears only if I add a drive id like C: or F: and use a full
path. The IE works properly and accepts full path with drive id. This problem
occurs in mozilla and in firefox.

Is there any solution for that? I have already tried to put "file://" and
"http://" in front of the path, but then the browser does not find the image
because he seems not to handle the path properly as well.

(Reporter)

Comment 3

14 years ago
Some more informations:

If I enter a windows path directly into the URL-field of the browser, i.e.:

F:\Internet\WWW\cms\cms\upload\productmgmt\images\staticdata\status_active.gif

with windows slahes "\" in the path, this path is converted by firefox and
mozilla automatically to 

file:///F:/Internet/WWW/cms/cms/upload/productmgmt/images/staticdata/status_active.gif

Result: the image is shown properly ==> no problem, correct behaviour!

As far as I use unix like slashes "/" in the path, i. e.

F:/Internet/WWW/cms/cms/upload/productmgmt/images/staticdata/status_active.gif

firefox reports an error in a pop window:

f is not a registered protocol

So, as far as I understand, this is a misbehaviour in firefox and mozilla. If
the first characters are not interpretable as a protocol (like http: or file:)
and the first character is alphabetic from A to Z followed by a doubledot (":"),
this should be interpreted as a file and should be shown in the same way like
with the other slashes (\).

I tested this with other files (i. e. textfile) ==> same misbehaviour

I hope, this will help You.
 




Comment 4

14 years ago
This is not a misbehavior, this is correct. See 269166 comment 2. This is invalid.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → INVALID
Version: unspecified → 1.0 Branch
You need to log in before you can comment on or make changes to this bug.