If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

fullscreen mode doesn't follow xrandr resolution changes

RESOLVED WORKSFORME

Status

()

Firefox
General
RESOLVED WORKSFORME
13 years ago
11 years ago

People

(Reporter: José Jorge, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5) Gecko/20041009 Firefox/1.0
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5) Gecko/20041009 Firefox/1.0

Firefox fullscreen doesn't reduce when xrandr has changed resolution, even
resizing the window.

But if I switch to a bigger resolution, as 1024x768, it works. So the problem is
only when lowering the resolution.


Reproducible: Always

Steps to Reproduce:
1.start firefox at 800x600
2.fullscreen mode works well
3.xrandr to 640x480
4.minimize/restore the firefox window to make it fit the new screen
5.press F11, the window is too big (it stays at 800x600)
Actual Results:  
firefox was bigger than the screen

Expected Results:  
follow the current resolution, rather than the resolution when started.

The bug can be turnarouded starting Firefox at the lowest resolution avaliable.
(Reporter)

Comment 1

13 years ago
(In reply to comment #0)
> Firefox fullscreen doesn't reduce when xrandr has changed resolution, even
> resizing the window.
> 
> But if I switch to a bigger resolution, as 1024x768, it works. So the problem is
> only when lowering the resolution.

I was wrong, retesting it showed me that Firefox allways uses the resolution of
the screen at start. So even switching to higher resolutions doesn't work.

> The bug can be turnarouded starting Firefox at the lowest resolution avaliable.

So this workaround is false.
This is an automated message, with ID "auto-resolve01".

This bug has had no comments for a long time. Statistically, we have found that
bug reports that have not been confirmed by a second user after three months are
highly unlikely to be the source of a fix to the code.

While your input is very important to us, our resources are limited and so we
are asking for your help in focussing our efforts. If you can still reproduce
this problem in the latest version of the product (see below for how to obtain a
copy) or, for feature requests, if it's not present in the latest version and
you still believe we should implement it, please visit the URL of this bug
(given at the top of this mail) and add a comment to that effect, giving more
reproduction information if you have it.

If it is not a problem any longer, you need take no action. If this bug is not
changed in any way in the next two weeks, it will be automatically resolved.
Thank you for your help in this matter.

The latest beta releases can be obtained from:
Firefox:     http://www.mozilla.org/projects/firefox/
Thunderbird: http://www.mozilla.org/products/thunderbird/releases/1.5beta1.html
Seamonkey:   http://www.mozilla.org/projects/seamonkey/

Comment 3

12 years ago
I have the same problem. Not only does the fullscreen function choose the wrong
size, the menus (file,edit,etc) will go past the end of the screen when you go
to a lower resolution (instead of moving to where they will fit).
I have this issue with both firefox 1.07 and 1.5b2

FYI:  There is a functioncalled XRRScreenChangeNotifyEvent provided by the
XRANDR X extention that will notify apps of screen configuration changes. See
<http://www.xfree86.org/4.4.0/Xrandr.3.html>.

Comment 4

11 years ago
This no longer happens with Firefox 2.0, but popup menus don't respect the new resolution, making them appear partially outside the screen. Should I file a new bug or morph this one into a more generic XRandR bug?
Assignee: bross2 → nobody
You should file a new bug about your issue. This bug, as filed, is now "works for me". Closing as such.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.