If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Add "Language-Pack" as a product to bugzilla

VERIFIED FIXED in Bugzilla old

Status

()

Bugzilla
Bugzilla-General
P3
normal
VERIFIED FIXED
18 years ago
5 years ago

People

(Reporter: Henrik Lynggaard Hansen, Assigned: Dawn Endico)

Tracking

unspecified
Bugzilla old
x86
Windows 98

Details

(Reporter)

Description

18 years ago
with the increased (to say the least) contributions of localizations, I think we 
can expect a vast amount of bug regarding spelled error, mis translations and 
the like for the different localizations.

I my opinion the right place for this kind of bug is currently 
browser-internalization. But I suggest a adding a "Language-Pack" product under 
bugzilla with the components being the different localizations.

the reason for this are (among other):

1. average users can have dificulties finding the right place 
(browser-internalization) especially if they saw the error in e.g. mail-news

2. The sheer number of possible bug, this will most likely overwhelm the owner 
of browser-internalization.

3. some bug reports might be written in the actual locale, or might be 
missing information about which locale has the problem,and this will make it 
harder to assign the rigth man,

image a bug like this:

"Jeg har lige downloadet den her MozScape ting, den er egentlig meget fed, og 
oversættelsen er også god, Jeg synes dog 'navn på adressebog' skal laves om til 
'adressebogens navn' Det lyder bedre"

how can easely assing this bug ?

* and with the number of localizations (38 at the time of writing) i think it is 
worth the work

4. having it split up, can automate many of the assignments, plus it seems 
logical to the avarege user.

Updated

18 years ago
Assignee: terry → leger

Comment 1

18 years ago
Reassigning to leger, as she'll be more likely to be tuned into relevant issues
than I am.

Comment 2

18 years ago
tao, bobj, what would you like me to do here?  Do you want this added as a new 
component?  Or do one of your current Intl components work for this?
Whiteboard: 02/19-Need bobj/tao input.
(Reporter)

Comment 3

18 years ago
As far as I know bugzilla then a component can't have sub components, thats why 
I suggest a language-pack PRODUCT with each localization being a COMPONENT

like this 

Language pack ->
  Danish - Denmark (defaults to Lynggaard@netscape.net for assignment and QA)
  Bosnien - Bosnia (defaults to Adnan)
  Japanese - Japan ( default to ....)
  and so on
  and so on
  for all 38+ localazations

this way no-one (e.g adnan)has to read thrugh alot of bugs to find the ones that 
he has to fix. 

This is way better than just cramming all the bugs into one component under the 
browser  product. 

a rough estimate of 38 localizations times 50 bugs per locale (properly a fair 
amount considering duplicates and invalids) = 1900 bug. 

Put that in a single component, then whoever has the default assignmet for that 
component will REAL busy. 

(Reporter)

Comment 4

18 years ago
I have asked for comments in netscape.public.mozilla.l10n

Comment 5

18 years ago
I like Henrik's idea in principle. I have additional thoughts:


1. Lang Packs created by volunteers should not be in the same category as Netscape L10n category.
   Netscape L10n might do its own localization and reporting of problems should not be
   mixed.
2. I think this will be a great tool for Lang Pack developers, but I wonder if average users
   will file a Bugzilla report -- so far they have not done so in great numbers. I suspect
   that there will be some language lang pack projects where there are a large number
   of interested high-end users, e.g. Japanese.
3. So how about establishing "Lang Pack" product category and include the lang-locale's under component
    if the owner of that lang-locale project feels this will be useful to them? This way
    we can start with a few and increase as needed. 
4. The owner of each lang-locale should take responsiblity in migrating a bug to 
   other products and components if it turns out that reported bugs have core origins.
   
(Reporter)

Comment 6

18 years ago
to momoi:

1. naturally

2.I think the average user, will ( or can be tought it) use the bugzilla system.
espesially if this is portrayed as the main feedback point

3.Although I thought it was less work to do it in one go, I undersatnd that 
added a small number in the beginning might be done.If so I would like the da-DK 
locale to be in the "first pack" so to speak

4. agreed

Comment 7

18 years ago
Tao, Bob, one of the most often heard complaints from many
Japanese volunteers is that there is a bug language
barrier in Bugzilla. It is a fact and we cannot wish this
away. 
I think we can use this idea by Lynggaard to harness the energy
of the Japanese volunteers. How about it? What is important is that
some volunteers in the Ja group will move bugs to teh English side
as needed. The volunteers can even write Japanese interface 
and make it part of English Bugzilla. I think we should open
up Bugzilla this way.

Comment 8

18 years ago
christine, dawn, what do you think? There is currently some discussion
going on in one of the Japanese mailing lists about setting
up Japanese version of Bugzilla because most of the Japanese volunteers
are hampered by a language barrier. We can harness more contributions
from these people if bugs can be filed in their own lnaguage. Then,
some volunteers will take responsibilties to move important bugs to
the English as needed. 
(Assignee)

Comment 9

18 years ago
I think setting up a japanese bugzilla would be an interesting idea and if
there is a big japanese mozilla community then it seems like a good idea to 
do this. However, here are the problems I see with doing this. 

- bugzilla wasn't originally set up to be localized so it will probably be
a lot of work to do so. (or it will be the first time at least)
- it will be a bit of work to maintain your copy of bugzilla and keep it running
- This doesn't scale very well for all 38+ localizations.
- What if you hacked bugzilla to make it localizable and provided a japanese
  localization. Then our copy of bugzilla could work in either language by
  adding a language argument. Once this work is done it would be easier for
  it to be localized into other languages.

What about doing this for languages with fewer bugs reported?
- Set up a localization product with one component per localization.
- Have each localizer set up a localized version of this page
  http://www.mozilla.org/quality/help/bug-form.html
- Make it so that the localized versions of the bugzilla helper submit all
  their bugs to their languages l10n component.
- l10n component owners (and their helpers) triage their bug lists by keeping
  the translation related bugs and translating and reassigning other bugs. For
  example, a danish user reports a bug with the layout engine. It initially 
  gets assigned to lynggaard who then translates it and reassigns it to the
  proper component.
- This wouldn't scale very well for languages with lots of non-english bug
  reporters. Getting volunteers to help triage and translate bug reports would
  help. Also you could possibly have your bug helper page ask people to only 
  submit bugs related to the localization itself and ignore all other bugs in
  a worst case situation.

apparently there's a big bugzilla localization thread in the webtools newsgroup
we should all read

Comment 10

18 years ago
I like Dawn's suggestion. See my comment below:

> - What if you hacked bugzilla to make it localizable and provided a japanese
>   localization. Then our copy of bugzilla could work in either language by
>   adding a language argument. Once this work is done it would be easier for
>   it to be localized into other languages.
> 

Someone need to look into the Bugzilla's localizibility issue before we 
commit to a localized bugzilla server.


> What about doing this for languages with fewer bugs reported?

> - Set up a localization product with one component per localization.
> - Have each localizer set up a localized version of this page
>   http://www.mozilla.org/quality/help/bug-form.html

> - Make it so that the localized versions of the bugzilla helper submit all
>   their bugs to their languages l10n component.

> - l10n component owners (and their helpers) triage their bug lists by keeping
>   the translation related bugs and translating and reassigning other bugs. For
>   example, a danish user reports a bug with the layout engine. It initially 
>   gets assigned to lynggaard who then translates it and reassigns it to the
>   proper component.

> - This wouldn't scale very well for languages with lots of non-english bug
>   reporters. Getting volunteers to help triage and translate bug reports would
>   help. Also you could possibly have your bug helper page ask people to only 
>   submit bugs related to the localization itself and ignore all other bugs in
>   a worst case situation.

Excellent idea. 

I also suggest that we recruit more volunteers for each language so that people
won't get worn out. Translation of all the bug reports could be very time
consuming and effort taking.


Thanks
(Assignee)

Comment 11

18 years ago
terry, what are your thoughts? I see there is a post from 
Olaf Kirche on 2/15/00 on the webtools group about localizing
bugzilla and apparently some discussion about this even earlier.

Comment 12

18 years ago
To add some more information. 
The JPN group decided to start up their own version of Bugzilla in
Japan for the following reasons primarily:

1. MySQL is not i18n'ed to do search/query in Japanese.
    (They got a Japanese capable version for their Bugzilla.)
2. They want the interface to be in JPN.

Volunteers will file mirror bugs in our Bugzilla as needed.

I wonder if search/query for Latin 1 data and other languages 
actually work on Bugzilla now. We know that it does not for JPN.
(Assignee)

Comment 13

18 years ago
momoi has some concerns that bugzilla's database (mysql) may not
be able to handle Latin1 characters. Lynggaard, could you test to
see if there are any problems with entering danish in bugs? I see
that this bug has some danish. Maybe you could search for "også" 
in the description field and if that works, create a test bug and
put it through its paces. Create a user with a "å" character in their
name, etc.

Apparently bugzilla won't work for cjk languages at all until 
mysql is updated.
(Reporter)

Comment 14

18 years ago
I have done 2 mini tests on bugzilla

test 1: search for æ in the summary, it returned my URLencode bug.

test 2: search for også in the description, and it returned this bug

seems to work

Comment 15

18 years ago
Henrik. That is good news for Latin 1. 
For Japanese, once in a while it works fortuitously.
But mostly it does not.

Comment 16

18 years ago
From reading through this summary, there seem to be two DIFFERENT problems
discussed here:
The problem the bug was originally reported on: Setting up a "Language-Pack"
product with current locales as products. All comments I see on that seem to say
"Yes, do it" - so what's the status here?
Side note: some talk to Asa Dotzler at #mozillazine showed that something like
that is really needed. He said he has sometimes Borwser-General bugs which seem
to only happen with one locale - but there's no way of assigning such a bug to
the locale owner...

The second problem is localization of BugZilla itself. I think that should be a
seperate bug report - and this is much harder to do - but dawn's "workaround"
seems to solve the problem to a certain extent for now...
Does someone file a bug report for it so we can seperate those problem? Should I
do that?

Comment 17

18 years ago
Do we have any idea on which cases Japanese works or does not work?

The problem referred to as the "localization of BugZilla itself" is a misnomer.
We should refer to this as the I18N enabling of Bugzilla.  Irrespective of
the localization, we should be able to search Bugzilla for Japanese or other
non-Latin1 data.

Could this problem be caused by certain byte clashes between SJIS and ASCII?  
Bugzilla or its underlying data base implementation may be doing byte-by-byte
instead of character-by-character processing.

If so, would a temporary workaround be to convert non-Latin1 data to an 
ASCII-compatible encoding (e.g., UTF-8)?  It might work better than storing
and searching in "native encodings" which map "non-ASCII" characaters with
"ASCII" byte values.
(Assignee)

Comment 18

18 years ago
To set up a localization product I need:

1) A description for the product that will show up 
in http://bugzilla.mozilla.org/enter_bug.cgi

2) a name for the product. I suppose "localization"
is good. "browser localization" would be better but
is probably too long.

3) a list of components. Each component needs a description,
an owner, and a qa contact.
(Reporter)

Comment 19

18 years ago
product: Localization
product description: Localizations of mozila.

component: da-DK or Danish 
component description: Danish translation of mozilla / Dansk oversættelse af 
Mozilla

default assign: lynggaard@netscape.net
qa: lynggaard@netscape.net

Comment 20

18 years ago
product: "Localization" - looks good for me.
product description: IMHO it should describe it better, Lyggaard. So what about
"Language Packs and localized builds of Mozilla" ??

component: please add "de-AT"
component description: German (Austria) translation & localisation of Mozilla / 
Deutsche (österreichische) Übersetzung von Mozilla
owner: KaiRo@StarTrekMail.com
QA: KaiRo@StarTrekMail.com - would be nice to find someone else here ;-)

Comment 21

18 years ago
Responding to KaiRo's comment on 3/19/2000, I think we can, for the time being, put aside
Localization into Japanese. Japanese volunteers are doing that themselves and hopefully will be
starting up their own server in Japan soon. It will be an interesting expriment and endico is helping 
as well. So, this RFE can be left alone for Henrik's original request.
(Reporter)

Comment 22

18 years ago
Kairo: I agree that the product description should be better than my first 
attempt :-) it was a quick hack in the middle of schoolwork.

I like your proposal

Comment 23

18 years ago
component: please add "nno-no" (three-letter ... please see <URL:http://www.egt.ie/standards/iso639/iso639-en.html>
component description: Norwegian (nynorsk) translation of Mozilla / Norsk (nynorsk) omsetjing av Mozilla
owner: huftis@bigfoot.com

Comment 24

18 years ago
Please add Dutch (nl) to BugZilla:

component: nl
component description: Dutch translation of Mozilla - Nederlandse vertaling van 
Mozilla
owner: cheezycrust@atmosphere.be
qa: cheezycrust@atmosphere.be (might change soon)

Comment 25

18 years ago
Hi, Jan/Dawn:


May I assume that a conclusion had been reached and the implementation is in 
progress?


Let me know if I can be of any help.

Thanks

Comment 26

18 years ago
Sending over to bobj...setting QA Contact to msanz.  What's the latest on 
possible doing this?
Assignee: leger → bobj
QA Contact: msanz

Comment 27

18 years ago
I assumed this was being "fixed" by endico@mozilla.org.
Assigning it to me won't get it fixed.  Reassiging to endico for now.
Assignee: bobj → endico
(Assignee)

Comment 28

18 years ago
I set up the product "Browser Localizations" with the description:
"For problems with translation, spelling and other errors in
particular language packs and localized builds of Mozilla.
Also for reporting browser bugs in languages other than english."

I added components for danish, dutch, german and norwegian. I'm
not terribly happy with the names but these can be changed later.
Everyone suggested using the language abbreviations, which make 
sense to localizers but I imagine are probably meaningless to 
most people. Our rule here is to use real words, not jargon.
Bug categories and descriptions should be chosen to make it
easier for users to file bugs correctly.

The best thing would have been to use the local language name
as the component name (dansk, deutche, etc) which would have
worked for these four languages but not for Hebrew and possibly
not even for French. Using just english is bad, and using just
the abbreviation is bad because its so cryptic. However, people
downloading de-AT builds may recognize the abbreviation if they
pay attention to the urls they click on so maybe that's not so 
bad. As a compromize i combined the the english name and the 
language code to form component names like "Danish/da-DK". Yes,
its ugly but at least the componets are there and people can get
started working. If people dislike this, reopen the bug and we can
discuss this more and change the component names later.
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED

Comment 29

18 years ago
Looks great!  Marking Verified for this initial setup.  If folks have changes 
needed, suggest writing a new bug.
Status: RESOLVED → VERIFIED

Comment 30

18 years ago
Please add:

component: Italian/ it-IT
component description: Italian translation of mozilla / Traduzione italiana di 
Mozilla

default assign: ciopz@iname.com
qa: axelware@tiscalinet.it
(Assignee)

Comment 31

18 years ago
added component for italian

Comment 32

18 years ago
I have noticed a bit late the news about this in the l10n newsgroup... I totally 
agree with Endico. Since Bugzilla has been written in Perl it shouldn't be 
difficult to make this thing work.

I agree that we should translate that Bugzilla Helper page. I would go even a 
step further. Some of us have made Mozilla sections on their pages and we could 
put Bugzilla Helper page on our site and the forms action attribute could point 
to 
action="http://bugzilla.mozill.org/...cgi?id=123&p1=bs-BA&p2=navigator&p3=x&p4=y
"

What do you think about that. It would increase even more the bug reporting of 
those people who are new to Internet (in Bosnia there are such people) and we 
are primarily helping them by translating Mozilla.

We could adapt the look of Bugzilla Helper page to our site but live the 
important element and form parts.

Cheers,

Adnan

Comment 33

18 years ago
Add this too:

Component: Bosnian/bs-BA
Component description: Bosnian translation of Mozilla / Prevod Mozille na 
bosanski

Default assign: aselimovic@internet.ba
QA: aselimovic@internet.ba
(Assignee)

Comment 34

18 years ago
added component for bosnian to browser localizations product.

aselimovic, i'm not sure what you meant by your comment about setting
the action field. Did you mean that using your localized helper form
should enter bugs into bugzilla like the normal one does? Yes, that's
what I meant. I think there should be some changes though. For instance,
your helper form should only assign bugs to the bosnian component even
if people have a problem with something else like layout. Or if you don't
have the resources to translate bug reports for the rest of the browser,
then just make a helper that's tailored towards just localization bugs
themselves.

Comment 35

18 years ago
endico,

well, I think that I can translate bugs for all the components. I want to make 
my own Helper Page where the people could only submit localization bugs for 
Bosnian component.

For other components people could still go to the Helper Page on mozilla.org.

Comment 36

18 years ago
Please Add this too:

Component: Bulgarian/bg-BG
Component description: Bulgarian translation of Mozilla / Превод на Mozilla на 
български

Default assign: bozhan@plov.omega.bg
QA: bozhan@plov.omega.bg
(Assignee)

Comment 37

18 years ago
added Bulgarian component. Please look at this url and make sure the 
Bulgarian part of the description is correct. I pasted it in from the
bug but since I don't have the proper font it looks like gibberish to
me. BTW, what font does Bulgarian require? 

http://bugzilla.mozilla.org/describecomponents.cgi?product=Browser%20Localizations
Whiteboard: 02/19-Need bobj/tao input.
Moving to Bugzilla product
Component: Bugzilla → Bugzilla-General
Product: Webtools → Bugzilla
QA Contact: msanz → matty
Target Milestone: --- → Bugzilla old
Version: other → unspecified
QA Contact: matty_is_a_geek → default-qa
You need to log in before you can comment on or make changes to this bug.