Context Menus in Multiple Displays

RESOLVED DUPLICATE of bug 245418

Status

()

Firefox
Shell Integration
RESOLVED DUPLICATE of bug 245418
13 years ago
13 years ago

People

(Reporter: J.W. Breeden, Assigned: Ben Goodger (use ben at mozilla dot org for email))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0

When using Firefox on a secondary display, the right-click context menu and all
of the dropdown menus (including Links Toolbar and Menu Bar), AND the
"autocomplete" boxes al show up on the Primary monitor, aligned to the side
where the secondary display fits. 


Reproducible: Always

Steps to Reproduce:
1. Install Firefox on a Multiple-Display System
2. Put firefox on a non-primary monitor
3. Use Context Menu and Menu Bars. 

Actual Results:  
Menus are placed on the primary display.

Expected Results:  
Menus should work as they do on the primary display.

Default Theme, NVidia Dualview Graphics Drivers, Windows XP Professional
controlling the Dualview system.

----------------------------------------
about:buildconfig

Build platform
target
i686-pc-cygwin

Build tools
Compiler 	Version 	Compiler flags
$(CYGWIN_WRAPPER) cl 	12.00.8804 	-TC -nologo -W3 -nologo -Gy -Fd$(PDBFILE)
$(CYGWIN_WRAPPER) cl 	12.00.8804 	-TP -nologo -W3 -nologo -Gy -Fd$(PDBFILE)

Configure arguments
--disable-ldap --disable-mailnews
--enable-extensions=cookie,xml-rpc,xmlextras,pref,transformiix,universalchardet,webservices,inspector,gnomevfs,negotiateauth
--enable-crypto --disable-composer --enable-single-profile
--disable-profilesharing --enable-optimize --disable-debug --disable-tests
--enable-static --disable-shared --enable-official-branding

*** This bug has been marked as a duplicate of 245418 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.