Show dependency graph -- no output using graphviz 2.2

RESOLVED INVALID

Status

()

Bugzilla
Query/Bug List
--
minor
RESOLVED INVALID
13 years ago
13 years ago

People

(Reporter: Greg Franks, Unassigned)

Tracking

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7) Gecko/20040616
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7) Gecko/20040616

I downloaded graphviz 2.2 from http://www.graphviz.org/Download..php. Compiled
and installed. Postscript, PNG, and GIF output all worked (at least using the
sample from the dot man page).  However, charting the bug dependency graphs
using bugzilla  2.18 stopped working.  Reverting to graphviz-1.10.20040107.0515
restored the plotting.  

Reproducible: Always

Steps to Reproduce:
1.download and install graphviz 2.2
2.Boink "show dependency graph" on any bug with dependencies.
3.

Actual Results:  
Broken image icon appears.

Expected Results:  
Display an image map.

The graphviz documentation (man dot) states: "There  are  also  two  deprecated
imagemap formats: -Tismap and -Tcmap...".  showdependencygraph.cgi is calling
dot with -Tismap

Comment 1

13 years ago
This probably has to do with a mismatch in your GD versions on the computer and
perl.

Please specify the version of Bugzilla you are using.

Comment 2

13 years ago
I'm getting this too -

/var/log/httpd/error_log has (for example):

[Fri May 20 17:46:53 2005] [error] [client 10.0.0.147] [Fri May 20 17:46:53
2005] showdependencygraph.cgi:
Use of uninitialized value in concatenation (.) or string at
/var/www/bugzilla/showdependencygraph.cgi line
 86., referer: http://10.0.0.6/bugzilla/show_bug.cgi?id=3534

and I get zero length .png and .map files.

OTOH, if I do (for example)
  
    # /usr/bin/dot -Tpng KDrAyjHG3l.dot > foo.png

I get a spiffy .PNG, so I don't think it's my installation.
With an earlier version of dot and 2.16.4, it was working.

I'm using 2.18.1 now (and GraphViz 2.2)

Comment 3

13 years ago
continuing from comment #2:

I uninstalled graphviz 2.2 and installed graphviz 1.9, and now the graphs work.
Only change in setup is now dot is at /usr/local/bin/dot (the default from
running configure, make, make install manually) instead of /usr/bin/dot (what
you get if you build the SRPM and install the RPMs)

Comment 4

13 years ago
"pacman" reported that GraphViz (2.0-1) was broken for him in a post to 
netscape.public.mozilla.webtools on Dec 23 2004, 2:51 pm
("Bugzilla dependency graph won't work"), so maybe something
changed with dot between GraphViz 1.9 and 2.0.

Comment 5

13 years ago
Added a -v in showdependencygraph.cgi for dot, for GraphViz version 1.9 getting

[Mon May 23 11:13:41 2005] [error] [client 10.0.0.147] Could not find/open font
: Times in /usr/X11R6/lib/X
11/fonts/TrueType:/usr/X11R6/lib/X11/fonts/truetype:/usr/X11R6/lib/X11/fonts/TTF:/usr/share/fonts/TrueType:
/usr/share/fonts/truetype:/usr/openwin/lib/X11/fonts/TrueType:/usr/X11R6/lib/X11/fonts/Type1,
referer: http
://10.0.0.6/bugzilla/show_bug.cgi?id=3534

So maybe this error is causing newer graphviz to fail completely (old graphviz
just uses monospaced font).

On command line, get 

/usr/bin/dot -v -Tpng vxGmK4Jx48.dot > foo.png
dot: fontname=Times-Roman fontpath=/usr/share/fonts/default/Type1/n021003l.afm
network simplex: 10 nodes 9 edges 0 iter 0.00 sec
mincross: pass 0 iter 0 trying 0 cur_cross 0 best_cross 0
mincross G: 0 crossings, 0.00 secs.
network simplex: 19 nodes 26 edges 3 iter 0.00 sec
routesplines: 9 edges, 27 boxes, 0 splines 0.00 sec
dot: allocating a 115K PaletteColor GD image

Comment 6

13 years ago
(In reply to comment #2)
> I'm getting this too -
> 
> /var/log/httpd/error_log has (for example):
> 
> [Fri May 20 17:46:53 2005] [error] [client 10.0.0.147] [Fri May 20 17:46:53
> 2005] showdependencygraph.cgi:
> Use of uninitialized value in concatenation (.) or string at
> /var/www/bugzilla/showdependencygraph.cgi line
>  86., referer: http://10.0.0.6/bugzilla/show_bug.cgi?id=3534
> 
> and I get zero length .png and .map files.
> 
> OTOH, if I do (for example)
>   
>     # /usr/bin/dot -Tpng KDrAyjHG3l.dot > foo.png
> 
> I get a spiffy .PNG, so I don't think it's my installation.
> With an earlier version of dot and 2.16.4, it was working.
> 
> I'm using 2.18.1 now (and GraphViz 2.2)

I'm seeing exactly what David's seeing.  Using GraphViz 2.2 and Bugzilla 2.8.1.    

Comment 7

13 years ago
> I'm seeing exactly what David's seeing.  Using GraphViz 2.2 and Bugzilla
2.8.1.    

That should say Bugzilla 2.18.1...sorry.

Comment 8

13 years ago
I removed graphviz 2.2 and installed 1.8.10-6 and the graphs work again.  So
it's definately related to graphviz 2.2.

Comment 9

13 years ago
My take is that something changed with GraphViz between versions 1.10 (worked
for Greg Franks) and 2.0-1 (didn't work for pacman).

I think the behavior that changed is that Bugzilla wants the Times font;  if
it's not available (say, not in the httpd user's path), the old version will
substitute a monospaced font, while the new version will silently produce no output.

I think GraphViz 2.0+ can be made to work, though, because I can get it to work
on the command line (because the Times font is in MY path?), but I don't know
enough about Perl to fix it. 

Comment 10

13 years ago
Turns out the answer was in the documentation all along:

2.1.5.3. GD (1.20)

The GD module is only required if you want graphical reports.

...

Tip	

The version of the GD module you need is very closely tied to the libgd version
installed on your system. If you have a version 1.x of libgd the 2.x versions of
the GD module won't work for you. 

RedHat 9 has the 1.8.4 gd RPM, so that's probably why GD version 2 won't work
right.  On RHEL 4 (actually CentOS 4.1), with gd 2.0.28, GD version 2<something>
works fine.

Probably should resolve this INVALID.

Updated

13 years ago
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → INVALID
(Reporter)

Comment 11

13 years ago
(In reply to comment #10)

> The version of the GD module you need is very closely tied to the libgd version
> installed on your system. If you have a version 1.x of libgd the 2.x versions of
> the GD module won't work for you. 

Perhaps checksetup.pl should insure that the version of libgd is compatible with
the version of graphviz.  Does this make sense?

Upgrading everything from Suse 7.3 to Suse 9.2 cleaned things up for me.
You need to log in before you can comment on or make changes to this bug.