pref enumeration can go into an infinite loop

VERIFIED FIXED in M17

Status

()

Core
Preferences: Backend
P3
normal
VERIFIED FIXED
18 years ago
18 years ago

People

(Reporter: (not reading, please use seth@sspitzer.org instead), Assigned: neeti)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

i just found this out:

I have some default prefs (in mailnews.js) that I'm trying to iterate through
and migrate.

my PrefEnumerationFunc gets all prefs that matches "ldap_2.server.*.description"
and tries to set those prefs to a migrate value.

this causes an infinite loop, it looks like setting a default pref (thus making
it appear in the users prefs.js) causes the problem.
neeti wrote:  How do I reproduce this bug? Does it happen on all platforms? 

to reproduce, you're going to have to write some code.  I changed the code I 
wrote (to work around this bug).

try to write some code that enumerates over all the 
"ldap_2.server.*.description" prefs and tries to set them in the enumeration 
call back.

I'm not sure if it happens on all platforms, but I would suspect that it did.

this is not a beta blocker, so if you have beta bugs, work on those first.
(Assignee)

Updated

18 years ago
Status: NEW → ASSIGNED
Target Milestone: M15
(Assignee)

Updated

18 years ago
Target Milestone: M15 → M16
(Assignee)

Updated

18 years ago
Target Milestone: M16 → M17
(Assignee)

Comment 2

18 years ago
This bug has been fixed by alecf's fix for bug 34199.
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED
verif.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.