crash if double-install an extension without resetting in between

RESOLVED WORKSFORME

Status

()

Toolkit
Add-ons Manager
--
critical
RESOLVED WORKSFORME
13 years ago
10 years ago

People

(Reporter: christophe tardif, Assigned: Ben Goodger (use ben at mozilla dot org for email))

Tracking

({crash})

1.7 Branch
x86
Windows XP
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0

When installing an extension, the host might lag and the user might double-click
the install link - causing a duplicate extension install dialog. If the user
installs the first one and not the second one, resetting firefox will cause the
profile to be corrupt, and will crash everytime it loads.

Reproducible: Always

Steps to Reproduce:
1.Find an extension to install
2.Click the install link two times (fast if the latency with the host is good)
3.Accept to install in the first occurance of the install prompt, but not the
second (why would a user double install an extension?)
4.Reset firefox
5.Watch it crash and never start again

Actual Results:  
Firefox WILL load, but it will instantly crash for an unknown reason - probably
caused by a corrupt profile

Expected Results:  
Instead of showing duplicate installation prompt, it should detect that there is
another one showing, and choose between closing it or not loading another.

Computer configuration (although i think it is irrelevant):
Everything is at stock clock speeds
Athlon 64 s754 2800+
ASUS k8n-e deluxe
ATI x800 pro AGP 8x
Pioneer DVD/RW
LG CD/RW
maxtor 200gb ata/133
maxtor 40gb ata/133
thermaltake va3400

Comment 1

13 years ago
Christophe Tardif: Could you provide Talkback incident ID of your crash?
Keywords: crash
(Reporter)

Comment 2

13 years ago
I can't reproduce this bug on windows XP PRO, which leads me to believe it is a 
bug on XP home. (found this while trying to reproduce the bug at my office to 
get the talkback incident ID)

Comment 3

13 years ago
christophe tardif: Was you successful with reproducing this crash on Windows XP
Home?
(Reporter)

Comment 4

13 years ago
(In reply to comment #3)
> christophe tardif: Was you successful with reproducing this crash on Windows XP
> Home?

not yet, maybe the bug was caused by another bug that was fixed in the two
previous releases? (1.01 and/or 1.02)

Comment 5

13 years ago
Okay, I'm marking this as WFM. Please reopen, if you could reproduce it and
provide Talkback. Thank you for cooperation.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → WORKSFORME
Version: unspecified → 1.0 Branch
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.