EMACS keybindings don't work, after changing ui.key.accelKey to 18 (alt)

VERIFIED DUPLICATE of bug 260572

Status

SeaMonkey
General
--
major
VERIFIED DUPLICATE of bug 260572
13 years ago
13 years ago

People

(Reporter: david raistrick, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (X11; U; FreeBSD i386; en-US; rv:1.8a6) Gecko/20050215
Build Identifier: Mozilla/5.0 (X11; U; FreeBSD i386; en-US; rv:1.8a6) Gecko/20050215


emacs keybindings fail to work, even after changing accelKey from Control to Alt.

In the Addressbar or a text input field

Ctrl+U does nothing  -- expect clear to beginning of line
Ctrl+A selects all text -- expect move curser to beginning of line


Support for these is referenced throughout the documentation. Example:
http://www.mozilla.org/access/keyboard/#modifiers


Previous builds, including Mozilla 1.8a2, supported this (even without switching
accelKey to Alt.).




Reproducible: Always

Steps to Reproduce:
1. user_pref("ui.key.accelKey", 18);
2. visit a page with text input field. 
3. input text.
4. press Ctrl+U
5. press Ctrl+A

Actual Results:  
Ctrl+U does nothing
Ctrl+A highlights all text in box.

Expected Results:  
Ctrl+U should clear to beginning of line
Ctrl+A should move cursor to beginning of line

Comment 1

13 years ago
See Bug 257405 Comment 46 or
http://kb.mozillazine.org/Emacs_Keybindings_(Firefox) for a workaround.

*** This bug has been marked as a duplicate of 260572 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.