url-encoded strings don't seem to be based on utf-8 encoding

VERIFIED DUPLICATE of bug 261929

Status

()

Firefox
General
VERIFIED DUPLICATE of bug 261929
14 years ago
14 years ago

People

(Reporter: Eric Covener, Assigned: Blake Ross)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0

When trying to access a URI that contains some non ascii,  such as
http://localhost/©.html (copyright symbol), firefox url-encodes as %A9 instead
of %C2%A9.  This seems to base the encoding on the unicode value u00A9 vs. the
utf-8 value C2A9


Reproducible: Always

Steps to Reproduce:
1. Browse to http://localhost/©.html
2. Note the url-encoded form of your URI


Actual Results:  
URL-encoded form doesn't appear correct, firefox encodes as:

http://localhost/%A9.html



Expected Results:  
Copyright symol should be encoded in utf-8 then percent-sign escaped

http://localhost/%C2%A9.html
Fixed back in December.

*** This bug has been marked as a duplicate of 261929 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.