"Copy Email Address" from contextual menu doesn't decode %XX chars in mailto: link

RESOLVED DUPLICATE of bug 215993

Status

()

Firefox
General
--
minor
RESOLVED DUPLICATE of bug 215993
13 years ago
13 years ago

People

(Reporter: Francois Bonzon, Assigned: Blake Ross)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0

When you "Copy Email Address" (in contextual menu after right-click) a mailto:
link with a so-called urlencoded address, as in name%40example.com, the address
stays undecoded in the clipboard.

Reproducible: Always

Steps to Reproduce:
See demo provided with the bug URL.
Actual Results:  
name%40example.com is in the clipboard.

Expected Results:  
name@example.com should instead be in the clipboard.

When you MouseOver such links, the correct decoded address appears in the status
bar. Also correctly decoded when you click it, and address inserted in the To:
field of a new message with your email client.
Fixed on trunk.

*** This bug has been marked as a duplicate of 215993 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.