address bar cannot restored to that of current tab

RESOLVED WORKSFORME

Status

()

Firefox
Tabbed Browser
RESOLVED WORKSFORME
13 years ago
13 years ago

People

(Reporter: Jeff, Assigned: Ben Goodger (use ben at mozilla dot org for email))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0

When I am in a tab, say, www.yahoo.com,   and key in new url in address bar,
say, www.espn.com.   then a new tab is created in foreground with this address.
  But when I switch to the original tab which is yahoo.com,  the address bar
shows a selected address (i mean blue backgraound and white character) of the
new address espn.com.  
I am using Tabbrowser Preferences 1.1.1.  




Reproducible: Always

Steps to Reproduce:
1. make sure the extension Tabbrowser Preferences 1.1.1 is installed.  and check
 the selection "URLs in address bar" under the item " Load the following in new
tab" in menu Tools->option

2. enter a new address www.yahoo.com in address bar.  
3. switch to the new created.
4. switch back to the first tab.  look at the address bar

Actual Results:  
address bar reads "www.yahoo.com" in selected mode.  

Expected Results:  
The address bar should display the original address of the current tab

How and when will I know if this bug is resolved?  thanks!

Comment 1

13 years ago
In order for this to processed in Bugzilla, you will need to reproduce it
without the Tabbrowser Extension.
(Reporter)

Comment 2

13 years ago
(In reply to comment #1)
> In order for this to processed in Bugzilla, you will need to reproduce it
> without the Tabbrowser Extension.

OK.  I uninstalled the tabbrowser extension.   but I cannot force the bowser to
open a new tab by key in a new address in the address bar.  So is this bug
belongs to the extension?  thanks. 

my user.js file consists of only 1 line:
user_pref("browser.tabs.showSingleWindowModePrefs", true);

Comment 3

13 years ago
You might be able to help me use Firefox.

If I have a open tab and I type a URL into the URL bar I expect it to
open in that tab. If I want it to open in a new tab, then I create the
tab first and then type. (The same applies to windows).

Are you saying that you can (or want to) have a keypress (Shift-Enter 
perhaps) that opens a new tab or window? [Shift does auto-complete
to .net so is not available; perhaps you caould distinguish between
Enter and Return ...].

FWIW, I would find this confusing and/or of low usability, and I wouldn't
use it!

What has this to do with your original report!
(Reporter)

Comment 4

13 years ago
(In reply to comment #3)
> You might be able to help me use Firefox.
> 
> If I have a open tab and I type a URL into the URL bar I expect it to
> open in that tab. If I want it to open in a new tab, then I create the
> tab first and then type. (The same applies to windows).
> 
> Are you saying that you can (or want to) have a keypress (Shift-Enter 
> perhaps) that opens a new tab or window? [Shift does auto-complete
> to .net so is not available; perhaps you caould distinguish between
> Enter and Return ...].
> 
> FWIW, I would find this confusing and/or of low usability, and I wouldn't
> use it!
> 
> What has this to do with your original report!

hi there. 
As you might have known, there is a very popular extension Tabbrowser
Preferences,  you can configure it to open a page at current tab or new tab.

hope it helps.

Comment 5

13 years ago
Comment 2 suggests that without the tabbrowser extension there is no
UI for you to open, from the URL bar, a URL into a new tab.

Yes it is possible that your bug is specific to systems with the
tabbrowser extension.

In general this does mean that it won't be processed in Bugzilla.

However if someone happens by who considers that your report does
indicate a defect in Firefox or that part of the tab browser
functionality should be included in the core, then something may
happen; but it is not to be expected.
This is an automated message, with ID "auto-resolve01".

This bug has had no comments for a long time. Statistically, we have found that
bug reports that have not been confirmed by a second user after three months are
highly unlikely to be the source of a fix to the code.

While your input is very important to us, our resources are limited and so we
are asking for your help in focussing our efforts. If you can still reproduce
this problem in the latest version of the product (see below for how to obtain a
copy) or, for feature requests, if it's not present in the latest version and
you still believe we should implement it, please visit the URL of this bug
(given at the top of this mail) and add a comment to that effect, giving more
reproduction information if you have it.

If it is not a problem any longer, you need take no action. If this bug is not
changed in any way in the next two weeks, it will be automatically resolved.
Thank you for your help in this matter.

The latest beta releases can be obtained from:
Firefox:     http://www.mozilla.org/projects/firefox/
Thunderbird: http://www.mozilla.org/products/thunderbird/releases/1.5beta1.html
Seamonkey:   http://www.mozilla.org/projects/seamonkey/

Comment 7

13 years ago
Reproduced in Firefox 1.0.7, safe mode, no tabbrowser extensions, win2k.
Steps:
- open www.google.com in a tab
- in the address bar, type www.yahoo.com, hit alt+enter
- yahoo displays in a new tab
- go back to google tab: the address bar still displays www.yahoo.com

Comment 8

13 years ago
works for me in Firefox 1.5 beta 2
Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8b5) Gecko/20051014
Firefox/1.4.1
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.