login pop-up window does not show up when accessing webpage (as it did in IE 6.0)

RESOLVED INVALID

Status

Toolkit Graveyard
Error Console
RESOLVED INVALID
14 years ago
2 years ago

People

(Reporter: Philip, Assigned: Ben Goodger (use ben at mozilla dot org for email))

Tracking

Details

(URL)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0

On my company's helpdesk webpage (http://63.84.230.90/magictsd) there is a login
pop-up window that should appear.  It does not, even though I have set Fiefox to
allow pop-ups and to allow the site.  I checked the Tools > Javascript Console
page, and the following error is displayed:  Error: window.showModalDialog is
not a function Source File: http://63.84.230.90/magictsd/  Line: 75

Not sure how to fix this.  This worked/works correctly in IE 6.0.

Reproducible: Always

Steps to Reproduce:
1.  type in URL
2.  pop-up window does not appear
3.

Actual Results:  
Nothing - pop-up window does not appear.

Expected Results:  
Login pop-up window should have appeared and allowed me to log into my site.

Comment 1

14 years ago
This is due to that window.showModalDialog is IE only. Not support by Mozilla.
Use window.open instead.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → INVALID
Product: Firefox → Toolkit
Product: Toolkit → Toolkit Graveyard
You need to log in before you can comment on or make changes to this bug.