Impossible to select rightmost tab if multiple tabs are open

RESOLVED DUPLICATE of bug 221684

Status

()

RESOLVED DUPLICATE of bug 221684
14 years ago
14 years ago

People

(Reporter: averk, Assigned: bugs)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; ru-RU; rv:1.7.5) Gecko/20041108 Firefox/1.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; ru-RU; rv:1.7.5) Gecko/20041108 Firefox/1.0

When too much tabs are opened or browser window is narrow enough, rightmost tabs
scroll out of client visual area and have no means to be selected.

Reproducible: Always

Steps to Reproduce:
1. Open much enough tabs (either to fill current tab layout fully or just 10-15
for later downsize)
2. Resize browser window until tabs stop reducing their size and scroll out of
right boundary.

Actual Results:  
Rightmost tabs disappeared and there's no means to select them.
In addition, same behavior is noticed for top menu and toolbar, link bar is a
good exception.

Expected Results:  
Either add chevron and drop menu as it does at link bar or add scroll buttons at
it done in usual system tab control.
Top menu and toolbar have to have chevrons as well.
There also should be a top-level menu item for tab selection if user uses tabs
in particular window (same style as bookmarks).

*** This bug has been marked as a duplicate of 221684 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.