Move from nsIScriptGlobalObject to nsIDocShell for disabling JS

RESOLVED FIXED

Status

()

--
minor
RESOLVED FIXED
14 years ago
14 years ago

People

(Reporter: timeless, Assigned: timeless)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 obsolete attachments)

(Assignee)

Description

14 years ago
It doesn't seem like we really need any of the magic that nsIScriptGlobalObject
provides, and if i can get editor to not use it, i think that would be a good
thing. there are two uses of sgo in editing session, the other is to get a non
refcounted pointer for GetDocShellFromWindow.
(Assignee)

Comment 1

14 years ago
Created attachment 175138 [details] [diff] [review]
use the docshell to disable scripts along with all the other children
Attachment #175138 - Flags: superreview?(jst)
Attachment #175138 - Flags: review?(brade)

Comment 2

14 years ago
Comment on attachment 175138 [details] [diff] [review]
use the docshell to disable scripts along with all the other children

I actually do approve of this but I'm marking it as r- because jst has a large
patch which includes some changes to the scripting flag (so it can be restored
to previous setting).  If jst wants to incorporate this tiny patch into his
patch, that is fine.

jst--when are you going to land?
Attachment #175138 - Flags: review?(brade) → review-
Comment on attachment 175138 [details] [diff] [review]
use the docshell to disable scripts along with all the other children

My changes landed, this'll need to be updated before reviewing...
Attachment #175138 - Flags: superreview?(jst) → superreview-
(Assignee)

Comment 4

14 years ago
Created attachment 175462 [details] [diff] [review]
second pass, recovered from jst's changes, almost killing presshell
Attachment #175138 - Attachment is obsolete: true
Attachment #175462 - Flags: superreview?(jst)
Attachment #175462 - Flags: review?(brade)

Updated

14 years ago
Attachment #175462 - Flags: review?(brade) → review+
Comment on attachment 175462 [details] [diff] [review]
second pass, recovered from jst's changes, almost killing presshell

sr=jst
Attachment #175462 - Flags: superreview?(jst) → superreview+
A bug that has a patch landed shouldn't really be in the UNCONFIRMED state. 
Bumping to NEW.
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Assignee)

Comment 7

14 years ago
Comment on attachment 175462 [details] [diff] [review]
second pass, recovered from jst's changes, almost killing presshell

mozilla/editor/composer/src/nsEditingSession.cpp	1.35
Attachment #175462 - Attachment is obsolete: true
(Assignee)

Updated

14 years ago
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.