undismissed context menu follows me on other virtual desktops

RESOLVED WORKSFORME

Status

()

Core
XUL
P3
normal
RESOLVED WORKSFORME
19 years ago
4 years ago

People

(Reporter: sairuh (rarely reading bugmail), Assigned: Mike Pinkerton (not reading bugmail))

Tracking

({helpwanted})

Trunk
Future
Other
Linux
helpwanted
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

19 years ago
have been seeing this for a week or so --not sure if it's expected behavior on
linux. non-issue on mac and winNT, afaik. unless it also occurs on
dual/tri-headed monitor systems --kinda like the "inverse" of bug 19347, heh.
;-)

1. bring up context menu with a single click of the right-mouse button. don't
select anything, just release the button so that the popup remains on the
screen.
2. move the mouse (still not holding down any buttons) to another virtual
desktop.

observe that the context menu follows you around, ie, it remains in the same
position on the screen, but it doesn't go away when you move over to another
desktop.

notes
-----
easily dismissed by returning to the original desktop (from which it was brought
up) and clicking anywhwere in the browser window.

context menu remains active while disembodied: ie, selecting Back will dismiss
it as well as take you to the previous webpage.

Comment 1

19 years ago
Kinda similar to bug 26509: menus and select boxes used to stay on top when you
Alt-Tabbed away from Mozilla.  Similar thing still happens with context menus:
right click to activate a contex menu, Alt-Tab to switch windows, context menu
will stay on top.
(Assignee)

Updated

19 years ago
Status: NEW → ASSIGNED
Target Milestone: M16
(Assignee)

Comment 2

19 years ago
post beta.

Comment 3

19 years ago
*** Bug 29540 has been marked as a duplicate of this bug. ***
(Assignee)

Updated

18 years ago
Target Milestone: M16 → M17

Comment 4

18 years ago
Mass moving M17 bugs to M18
Target Milestone: M17 → M18

Comment 5

18 years ago
mass-moving all bugs to m21 that are not dofood+, or nsbeta2+
Target Milestone: M18 → M21
(Reporter)

Comment 6

18 years ago
*spam*: transferring current XP Menu bugs over to jrgm, the new component owner.
feel free to add me to the cc list (unless am the Reporter) of any of these, if
you have any questions/etc.
QA Contact: sairuh → jrgm
(Assignee)

Comment 7

18 years ago
pav: what is different in the case of virtual desktop switching? why would it be
any different than switching windows? if it's not then i don't know what to do here.

i'll let this one hang out for a bit, but it's a very good candidate for futuring.
Target Milestone: M21 → ---

Comment 8

18 years ago
-> future
Target Milestone: --- → Future
(Reporter)

Updated

18 years ago
Keywords: helpwanted

Comment 9

18 years ago
*** Bug 47421 has been marked as a duplicate of this bug. ***

Comment 10

18 years ago
*** Bug 58401 has been marked as a duplicate of this bug. ***

Comment 11

15 years ago
this bug hasn't been touched since forever. does the problem still
persist?
(Reporter)

Comment 12

15 years ago
hm, i cannot repro this with today's build on linux rh8.0 --then again, my
window mgr (metacity) is setup such that i need to use a keyboard shortcut to
switch virtual desktops... i've another machine (rh7.2) where moving the mouse
switches at the edge, will check that later on.
(Reporter)

Comment 13

15 years ago
no longer an issue on linux rh7.2 (sawfish) --if the context menu is up, i
cannot move to another desktop moving the mouse.

marking w4m (invalid?).
Status: ASSIGNED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → WORKSFORME

Updated

10 years ago
Component: XP Toolkit/Widgets: Menus → XUL
QA Contact: jrgmorrison → xptoolkit.widgets

Updated

4 years ago
blocking-b2g: --- → koi?
Mass-modify - removal of no longer relevant blocking flags.

Updated

4 years ago
blocking-b2g: koi? → ---
You need to log in before you can comment on or make changes to this bug.