Last Comment Bug 283229 - [BC]Table rows have multiple lines when scrolling
: [BC]Table rows have multiple lines when scrolling
Status: RESOLVED WORKSFORME
:
Product: Core
Classification: Components
Component: Layout: Tables (show other bugs)
: Trunk
: x86 Windows XP
: -- minor with 2 votes (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
Mentors:
http://dave.joanddave.co.uk/bugzilla/...
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2005-02-22 14:49 PST by David McKenzie
Modified: 2010-02-24 22:53 PST (History)
7 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
The bug in action. (26.05 KB, image/png)
2005-02-22 14:52 PST, David McKenzie
no flags Details
testcase (3.56 KB, text/html)
2006-01-08 12:21 PST, Martijn Wargers [:mwargers] (not working for Mozilla)
no flags Details
Another testcase using a form select element (1.05 KB, text/html)
2010-02-10 11:39 PST, Mark D.
no flags Details

Description David McKenzie 2005-02-22 14:49:19 PST
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0

In the page http://www.gla.ac.uk/clubs/guns/bugzilla08.xhtml I noticed that the
table lines started drawing twice when the browser is scrolled.

Picture here:
http://www.gla.ac.uk/clubs/guns/bugzilla02.png

I have tried to reproduce on Mozilla 1.75 and the recent trunk build on Firefox
as well as Firefox 1.0. They all have the same behaviour.

Reproducible: Sometimes

Steps to Reproduce:
1. Load the page http://www.gla.ac.uk/clubs/guns/bugzilla08.xhtml
2. scroll with the mouse from the bottom to the top of the page in about 1
second (using screen res 1280*1024 with firefox window size occupying about
1024*800 in the middle)
3. If that does not work, try again slowly. Control F5 (force refresh) sometimes
helps in seeing the effect

Actual Results:  
The table row lines (the horizontal ones) are sometimes drawn twice.
You'll immediately see the result here:
http://www.gla.ac.uk/clubs/guns/bugzilla02.png

Expected Results:  
Table rows should only be drawn once.

Seems to be across the suite. Mozilla, firefox and firefox nightly (trunk) all
seem to act the same.

Have not checked that it is html or xhtml dependant. 

The file uses xhtml and a stylesheet, you can view source if you want to see.
Comment 1 David McKenzie 2005-02-22 14:52:14 PST
Created attachment 175217 [details]
The bug in action.

Screenshot of the bug
Comment 2 Raj Bhaskar 2005-02-22 15:21:58 PST
I also see this on Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8a5)
Gecko/20041119 MultiZilla/1.8.0.1c (trunk build)

I found that the browser window has to be small enough to let the document
scroll by a full page to be able to reproduce.
Comment 3 Boris Zbarsky [:bz] 2005-02-25 09:23:52 PST
Are people seeing this without smoothscrolling enabled?

Also, are they seeing it with builds after 2005-02-03?
Comment 4 Raj Bhaskar 2005-02-25 10:17:11 PST
Boris, I can't reproduce with smooth scrolling off (on the build mentioned in
comment 2).

Also, I've noticed that I can only reproduce the bug when smooth scrolling is on
if I use the mouse wheel to scroll back up again (with prefs set to scroll the
document by the system default number of lines).
Comment 5 Boris Zbarsky [:bz] 2005-02-25 10:24:09 PST
Yeah, if smoothscrolling is involved you definitely want to test builds after
2005-02-03.  See bug 280041.
Comment 6 David McKenzie 2005-02-25 11:01:06 PST
(In reply to comment #3)
> Are people seeing this without smoothscrolling enabled?

Yes, Mozilla 1.75 and firefox 1.0 are still showing the effect with
smoothscrolling and autoscroll off.

> Also, are they seeing it with builds after 2005-02-03?

Yes, I tried with the recent firefox trunk build and it still appears broken.

(In reply to comment #4)
I don't have a scroll wheel. I'm just using the middle mouse to scroll down. Can
you recreate the bug with the scroll wheel?
Comment 7 David McKenzie 2005-02-25 11:09:16 PST
(In reply to comment #6)
> I'm just using the middle mouse to scroll down. 

I should have said, I was using the scroll bar on the right to scroll down. With
autoscrolling off the middle mouse doesn't scroll. Sorry for the misleading comment.
Comment 8 Raj Bhaskar 2005-02-25 16:52:51 PST
I've just tested in Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b2)
Gecko/20050225 and the effect is still present.

It seems that I was wrong about a few things though:
* It happens with or without smooth scrolling enabled
* It is reproducable with the window scroll bar as well as the mouse scroll wheel

Also, resizing the window removes the artefact.
Comment 9 Gérard Talbot 2005-04-05 04:43:40 PDT
I see some horizontal row lines sometimes drawn twice when dragging the
scrollbar thumb. 
I do NOT see this layout bug when using Up/Down arrow keys or PgUp/PgDn keys or
Home/End keys or when clicking the scrollbar ^/v arrows or when rolling
mousewheel. I have smooth scrolling disabled. I have not tried with autoscroll.

Mozilla 1.8b2 build 2005040305 under XP Pro SP2 here.

I could not find a duplicate for this. 

Setting severity to minor since this is not always happening, not happening
under many conditions, not creating a huge layout problem.

CONFIRMING
Comment 10 Boris Zbarsky [:bz] 2005-04-05 08:19:55 PDT
Over to the right product and (maybe) right component...  Bugs in General aren't
exactly on anyone's "to fix" list.
Comment 11 Martijn Wargers [:mwargers] (not working for Mozilla) 2006-01-05 09:54:42 PST
The url is not there anymore. Reporter could you please attach the testcase to this bug?
Comment 12 David McKenzie 2006-01-07 15:45:00 PST
> In the page I noticed that the
> table lines started drawing twice when the browser is scrolled.
> 
> Picture here:

I changed the website over and forgot about the links. Oops.

The new files are up at:
http://dave.joanddave.co.uk/bugzilla/bugzilla08.xhtml
http://dave.joanddave.co.uk/bugzilla/bugzilla02.png

For the bug and the picture showing the bug.

The bug still exists in Firefox 1.5 and SeaMonkey 1.0b.
Comment 13 Gérard Talbot 2006-01-07 17:59:57 PST
URL field updated accordingly
Comment 14 Martijn Wargers [:mwargers] (not working for Mozilla) 2006-01-08 12:21:08 PST
Created attachment 207912 [details]
testcase

It's always better to attach the testcase to the bug.
I can see the bug too in current trunk build, btw.
Comment 15 Boris Zbarsky [:bz] 2006-01-08 20:05:59 PST
mmm border-collapse.
Comment 16 Ryan VanderMeulen [:RyanVM] 2008-09-30 16:30:48 PDT
I can't reproduce this with a current 3.0.3 build. Can anybody else?
Comment 17 Bernd 2009-08-23 22:23:53 PDT
I can with todays nightly
Comment 18 Mark D. 2010-02-10 11:39:23 PST
Created attachment 426293 [details]
Another testcase using a form select element

I found this bug in Firefox 3.6 (on OSX 10.5) and have attached another test case which makes it super easy to reproduce.

Testing both test cases on trunk (Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.3a2pre) Gecko/20100210 Minefield/3.7a2pre) reveals that both are fixed. Wohoo!
Comment 19 Bernd 2010-02-10 11:55:41 PST
chances are hih that this is caused by the fix for bug 452319 http://hg.mozilla.org/mozilla-central/rev/91e00d39570f

Note You need to log in before you can comment on or make changes to this bug.