http://www.circuitcity.com displays as binary garbage

RESOLVED WORKSFORME

Status

()

Firefox
General
--
major
RESOLVED WORKSFORME
13 years ago
13 years ago

People

(Reporter: Kevin George, Assigned: Blake Ross)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040614 Firefox/0.8
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040614 Firefox/0.8

This happens to me about 90% of the time.  When I go to
http://www.circuitcity.com,  all I see is a bunch of binary garbage, instead of
the page.  None of the page loads correctly.  I used ethereal to take a trace,
and it shows the request/response below.  The server said it was sending gzip
encoding and no body, just headers.  Then it closed the connection.

The same symptom occurs in Windows and MacOS X versions of the browser.

I'm guessing that maybe we running the gzip decoder on some unitialized memory,
or not handling error cases from the gzip decoder directly?  Just a guess.


GET
http://www.circuitcity.com/ccd/home.do?com.broadvision.session.new=Yes&BV_UseBVCookie=No
HTTP/1.1

Host: www.circuitcity.com

User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040614
Firefox/0.8

Accept:
text/xml,application/xml,application/xhtml+xml,text/html;q=0.9,text/plain;q=0.8,video/x-mng,image/png,image/jpeg,image/gif;q=0.2,*/*;q=0.1

Accept-Language: en-us,en;q=0.5

Accept-Encoding: gzip,deflate

Accept-Charset: ISO-8859-1,utf-8;q=0.7,*;q=0.7

Keep-Alive: 300

Proxy-Connection: keep-alive

Cookie: BV_IDS=ccccadddmdjlglkcfngcfkmdffhdfgo.0:@@@@1801710802.1109121215@@@@;
lastvisit=02/22/05 20:13:35; firstvisit=<02/08/05 21:49:54; visitcount=30;
tvsweeps=yes; guestid=1254423950.1107917394.cccladddkllhjmkcfngcfkmdffhdffh.0; ct=0

Cache-Control: max-age=0



HTTP/1.1 200 OK

Server: Sun-ONE-Web-Server/6.1

Date: Wed, 23 Feb 2005 01:15:06 GMT

Content-type: text/html;charset=ISO-8859-1

Pragma: no-cache

Cache-Control: no-cache

Cache-Control: no-store

Cache-Control: must-revalidate

Set-cookie:
BV_IDS=ccchadddmdjlgmlcfngcfkmdffhdfgo.0:@@@@0123630966.1109121305@@@@; path=/;
domain=.circuitcity.com

Set-cookie: firstvisit=<02/08/05 21:49:54; path=/; expires=Saturday, 23-Feb-2008
01:15:05 GMT; domain=.circuitcity.com

Set-cookie: lastvisit=02/22/05 20:15:05; path=/; expires=Saturday, 23-Feb-2008
01:15:05 GMT; domain=.circuitcity.com

Set-cookie: visitcount=31; expires=Saturday, 23-Feb-2008 01:15:05 GMT; path=/;
domain=.circuitcity.com;

P3P: P3P: CP='CAO DSP COR CURa DEVa PSAa OUR BUS ONL UNI PRE'

Content-encoding: gzip

Vary: accept-encoding

Connection: close

Content-Length: 6894

Content-Encoding: gzip


Reproducible: Sometimes

Steps to Reproduce:
1. Go to http://www.circuitcity.com/ in firefox.
2. Garbage appears in the browser window.
3. If the page loaded correctly, try hitting 'reload' until it fails to load
correctly.

Actual Results:  
All I saw was garbled text in the browser window.

Expected Results:  
The page should have loaded correctly with images, etc.
(Reporter)

Comment 1

13 years ago
I should have been more clear - when I said:

"The server said it was sending gzip encoding and no body, just headers.  Then
it closed the connection."

I meant that the server sent headers including a Content-Length (6894) and a
Content-Encoding of gzip.  However, it sent no body back to the browser.

The browser then displayed some garbled text where I would expect the html
document to appear.
(Reporter)

Comment 2

13 years ago
Created attachment 175247 [details]
Ethereal libpcap formatted packet trace showing the bug occuring

For the purpose of this trace, I set a proxy in my browser to 127.0.0.1:8080 to
avoid a local web proxy/cache.	The bug occurs regardless of whether I'm going
through the proxy.

The interesting connection starts at frame #41 (GET request on frame 44).

Comment 3

13 years ago
Seeing this on Windows too Mozilla 2005/01/23, and Firefox Mozilla/5.0 (Windows;
U; Windows NT 5.1; en-US; rv:1.8b2) Gecko/20050220 Firefox/1.0+

This should be in tech evang or core.
OS: Linux → All

Comment 4

13 years ago
I'm seeing this problem too on Mac OS X 10.3.8 on Mozilla 1.8a6 [Mozilla/5.0
(Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8a6) Gecko/20050111].

The "Hardware" field on this bug should probably be changed to "All"

Comment 5

13 years ago
At the moment I get only a 302 to close.html which says "We're updating our site
with new products and information. Please check back in a few minutes.".
Hardware: PC → All

Comment 6

13 years ago
I am going to check this a few more times over the next week or two. If I don't
see the problem again and no one else makes a comment that they are still seeing
it I will resolve WFM. No dupes of this bug have been filed, I checked for
circuitcity in the summary and the URL.

Comment 7

13 years ago
WFM - Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b2) Gecko/20050601
Firefox/1.0+
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.