Query results don't give clear indication when LOGGED OUT

VERIFIED DUPLICATE of bug 29240

Status

()

P3
critical
VERIFIED DUPLICATE of bug 29240
19 years ago
6 years ago

People

(Reporter: selmer, Assigned: justdave)

Tracking

Details

(Reporter)

Description

19 years ago
build 2000-02-17-09

This is probably a forms submission bug in Seamonkey, but that's just a theory
so I'll start here.

I queried on

status=uncomfirmed|new|assigned|reopened
assignedto=racham
status_whiteboard=pdt+

in 4.x, I get 2 bugs (19621,27797) , in Seamonkey I get zarro boogs.
(Reporter)

Comment 1

19 years ago
Adding component owners of forms submissions to the CC list.

Comment 2

19 years ago
If you can get different behavior from Bugzilla between 4.x and Seamonkey, then
it is by definition a backwards-compabatability bug in Seamonkey.  Reassigning.
Assignee: terry → karnaze
Component: Bugzilla → Form Submission
Product: Webtools → Browser
QA Contact: ckritzer

Comment 3

19 years ago
Eric, can you verify that the query url is the same as Nav.
Assignee: karnaze → pollmann

Comment 4

19 years ago
Last time I saw a bug like this it was because a bugzilla login cookie was set
in one but not the other (4.x but not mozilla)  Thus 4.x returned bugs that were
visible to internal only while mozilla did not.  This was fixed by logging in
with mozilla.

Steve, what were the bugs that you saw in one but not the other?

Thanks!
(Reporter)

Comment 5

19 years ago
Yes, the two bugs I listed are internal only.  So, now I'm going to send this 
back to Terry as a request for either login state to be prominent on all pages, 
or for query results to indicate the need to login to see all the results.

Terry?
Assignee: pollmann → terry

Comment 6

19 years ago
I also experience errors in form submissions. It happened to me on:
http://www.agralin.nl/desktop/catalog/rightframe.html
I fill in the form for searching and the fields are submitted under a wrong name
or something. E.g. when I search for library: BIOCHE nothing is found because
the query results in `basic "bioche"' whereas under Netscape 4.7 the query
becomes: `lib "bioche"'. This under build 2000031317.

Comment 7

19 years ago
Changing component.  Which will also change owner, as there is a new owner for
all Bugzilla bugs (see my posting in netscape.public.mozilla.webtools,
news://news.mozilla.org/38F5D90D.F40E8C1A%40geocast.com .)
Assignee: terry → tara
Component: Form Submission → Bugzilla
Product: Browser → Webtools
QA Contact: ckritzer → matty

Comment 8

18 years ago
is this still an issue?
(Reporter)

Comment 9

18 years ago
I guess, technically, my complaint has been fixed.  The yellow box at the bottom
of the page shows whether the result is from logged in or not.  However, what I
really wanted was for the query results list to have an indication that some
information was left out because I wasn't logged in.  If that indicator were a
link that logged me in and then showed the complete information, that would be
swell.  This is just one of those little changes that would help me avoid making
stupid mistakes.

I have no idea if the comment from Jos.vandenOever@fenk.wau.nl is actually
related or not.
Whiteboard: 2.14
(Reporter)

Comment 10

18 years ago
Changing the summary to reflect the current state of this bug.  I'd like to see
the query results give some clear indication that the results are incomplete
since I didn't log in.
Summary: Query gives different results in 4.x vs Seamonkey → Query results don't give clear indication when LOGGED OUT

Updated

18 years ago
Whiteboard: 2.14 → 2.16
moving to real milestones...
Target Milestone: --- → Bugzilla 2.16

*** This bug has been marked as a duplicate of 29240 ***
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE
Whiteboard: 2.16
moving to Bugzilla product
reassign to default owner/qa for INVALID/WONTFIX/WORKSFORME/DUPLICATE
Assignee: tara → justdave
Component: Bugzilla → Bugzilla-General
Product: Webtools → Bugzilla
Target Milestone: Bugzilla 2.16 → ---
Version: other → unspecified

Comment 14

17 years ago
Verified duplicate
Status: RESOLVED → VERIFIED
QA Contact: matty_is_a_geek → default-qa
You need to log in before you can comment on or make changes to this bug.