Last Comment Bug 283289 - Unable to read a mail containing a charset "MACINTOSH"
: Unable to read a mail containing a charset "MACINTOSH"
Status: RESOLVED DUPLICATE of bug 237712
:
Product: Thunderbird
Classification: Client Software
Component: General (show other bugs)
: 1.0
: x86 Windows XP
: -- normal (vote)
: ---
Assigned To: Scott MacGregor
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2005-02-23 03:17 PST by Guillaume
Modified: 2005-02-23 06:18 PST (History)
0 users
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments

Description Guillaume 2005-02-23 03:17:40 PST
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; fr-FR; rv:1.7.5) Gecko/20041108 Firefox/1.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; fr-FR; rv:1.7.5) Gecko/20041108 Firefox/1.0

While recieving mail containing charset=MACINTOSH as MIME, Thunderbird can't
read correctly "special characters".

It shows "�" char instead of showing chars like é, è, à etc.

For example (in french) it shows the following text :
"installes un �diteur de texte"
instead of :
"installes un éditeur de texte"

Reproducible: Always

Steps to Reproduce:
1. A mail was send by a "Macintosh" computer using charset "MACINTOSH" and
special chars
2. Read the message with thunderbird

Actual Results:  
text sample :

installes un �diteur de texte

Expected Results:  
installes un éditeur de texte

no crash
Comment 1 OstGote! 2005-02-23 04:33:11 PST
Perhaps this is related to Bug 237712. Could you please test it with a TB 1.0.1
build (or wait for the TB 1.0.1 release) from
http://ftp.eu.mozilla.org/pub/mozilla.org/thunderbird/nightly/latest-aviary1.0.1/

If it works it is a duplicate of the mentioned bug.
Comment 2 Guillaume 2005-02-23 05:56:02 PST
I tested it with TB 1.0.1
it works properly

thanks,
sorry for reporting a duplicate bug...
Comment 3 OstGote! 2005-02-23 06:18:17 PST

*** This bug has been marked as a duplicate of 237712 ***

Note You need to log in before you can comment on or make changes to this bug.