Last Comment Bug 283318 - Errors in mail_help.xhtml
: Errors in mail_help.xhtml
Status: RESOLVED FIXED
: fixed1.8
Product: SeaMonkey
Classification: Client Software
Component: Help Documentation (show other bugs)
: unspecified
: x86 Windows 2000
: -- trivial (vote)
: seamonkey1.0beta
Assigned To: Documentation/Help bugs
: Daniel Wang
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2005-02-23 07:23 PST by Alexander L. Slovesnik
Modified: 2005-12-10 08:22 PST (History)
4 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
Fix for a few errors. (11.00 KB, patch)
2005-12-07 10:02 PST, Giacomo Magnini
iann_bugzilla: review+
Details | Diff | Review
Updated per comments and checkins... ;) (Checked into trunk/branch) (9.95 KB, patch)
2005-12-08 15:30 PST, Giacomo Magnini
prometeo.bugs: review+
kairo: approval‑seamonkey1.0+
Details | Diff | Review

Description Alexander L. Slovesnik 2005-02-23 07:23:04 PST
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; ru-RU; rv:1.7.5) Gecko/20041107 Firefox/1.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; ru-RU; rv:1.7.5) Gecko/20041107 Firefox/1.0

http://lxr.mozilla.org/mozilla/source/extensions/help/resources/locale/en-US/mail_help.xhtml#2081

<p><strong>Tip</strong>: Communicator address book files (pab.na2) are stored in
your user profile directory (for example, C:\Program
Files\&brandShortName;\Users, where \Users contains the user profiles
directories).</p>

I guess that Netscape Communicator is usually installed in C:\Program
Files\Netscape\, not C:\Program Files\Mozilla\

http://lxr.mozilla.org/mozilla/source/extensions/help/resources/locale/en-US/mail_help.xhtml#2095

You can export an address book to one of these file formats: &brandShortName; 
(.ldif), tab-delimited (.tab), comma-separated (.csv), or text (.txt) formats.</p>

What is &brandShortName; (.ldif) format?

Reproducible: Always
Comment 1 Stefan [:stefanh] (away until May 28) 2005-02-23 09:18:54 PST
(In reply to comment #0)

> <p><strong>Tip</strong>: Communicator address book files (pab.na2) are stored in
> your user profile directory (for example, C:\Program
> Files\&brandShortName;\Users, where \Users contains the user profiles
> directories).</p>
> 
> I guess that Netscape Communicator is usually installed in C:\Program
> Files\Netscape\, not C:\Program Files\Mozilla\
> 

Yes but &brandShortname; is an entity. So a vendor like Netscape will substitute
"Mozilla" with "Netscape" in
http://lxr.mozilla.org/seamonkey/source/xpfe/global/resources/locale/en-US/brand.dtd.
Netscape users will then get the right path.

> What is &brandShortName; (.ldif) format?

If you're using Mozilla, that would be Mozilla (.ldif) format.

Please resolve as invalid if those were the errors you wanted to report.

Thanks
Comment 2 Alexander L. Slovesnik 2005-02-23 09:32:50 PST
(In reply to comment #1)
> (In reply to comment #0)
> 
> > <p><strong>Tip</strong>: Communicator address book files (pab.na2) are stored in
> > your user profile directory (for example, C:\Program
> > Files\&brandShortName;\Users, where \Users contains the user profiles
> > directories).</p>
> > 
> > I guess that Netscape Communicator is usually installed in C:\Program
> > Files\Netscape\, not C:\Program Files\Mozilla\
> > 
> 
> Yes but &brandShortname; is an entity. So a vendor like Netscape will substitute
> "Mozilla" with "Netscape" in
>
http://lxr.mozilla.org/seamonkey/source/xpfe/global/resources/locale/en-US/brand.dtd.
> Netscape users will then get the right path.
> 

May be Netscape users will get right path, but Mozilla Suite users are got wrong
path.
Here comes cut&paste from Mozilla Suite Help:
-----------------------------------------------
Tip: Communicator address book files (pab.na2)
are stored in your user profile directory (for example, C:\Program
Files\Mozilla\Users, where \Users contains the user profiles
directories).
----------------------------------------------

> > What is &brandShortName; (.ldif) format?
> 
> If you're using Mozilla, that would be Mozilla (.ldif) format.
> 

LDIF is not format invented by Mozilla, I guess. Right now is sounds like
proprietary Mozilla format. I think that phrase should sound like:

You can export an address book to one of these file formats: LDIF 
(.ldif), tab-delimited (.tab), comma-separated (.csv), or text (.txt) formats

Comment 3 Stefan [:stefanh] (away until May 28) 2005-02-23 09:55:58 PST
> Here comes cut&paste from Mozilla Suite Help:
> -----------------------------------------------
> Tip: Communicator address book files (pab.na2)
> are stored in your user profile directory (for example, C:\Program
> Files\Mozilla\Users, where \Users contains the user profiles
> directories).
> ----------------------------------------------

Aha, you mean that the path 'C:\Program Files\Mozilla\Users'is wrong (I'm on a
mac). Wouldn't this require a lot of different paths depending on what windows
version/log-in/not log-in a user has? Also, paths differ according to OS
(mac/win/*nix).

> LDIF is not format invented by Mozilla, I guess. Right now is sounds like
> proprietary Mozilla format. I think that phrase should sound like:
> 
> You can export an address book to one of these file formats: LDIF 
> (.ldif), tab-delimited (.tab), comma-separated (.csv), or text (.txt) formats
> 

Makes sence, hmm we should probably explain LDIF in a simple way... 

Comment 4 Alexander L. Slovesnik 2005-02-23 10:11:13 PST
(In reply to comment #3)
> > Here comes cut&paste from Mozilla Suite Help:
> > -----------------------------------------------
> > Tip: Communicator address book files (pab.na2)
> > are stored in your user profile directory (for example, C:\Program
> > Files\Mozilla\Users, where \Users contains the user profiles
> > directories).
> > ----------------------------------------------
> 
> Aha, you mean that the path 'C:\Program Files\Mozilla\Users'is wrong (I'm on a
> mac). Wouldn't this require a lot of different paths depending on what windows
> version/log-in/not log-in a user has? Also, paths differ according to OS
> (mac/win/*nix).
> 

That's just example. On Windows Netscape are usually installed in C:\Program
Files\Netscape\. All that should be done is to replace C:\Program
Files\&brandShortName;\Users with C:\Program Files\Netscape\Users

I can make a patch, if you want.

Comment 5 Stefan [:stefanh] (away until May 28) 2005-02-24 10:32:53 PST
> That's just example. On Windows Netscape are usually installed in C:\Program
> Files\Netscape\. All that should be done is to replace C:\Program
> Files\&brandShortName;\Users with C:\Program Files\Netscape\Users

OK, so the point is that for Netscape users the path is correct. But not for
mozilla users? Hmm, Ian - what do you think? I must say I would prefer that we
gave the correct Mozilla path and not the Netscape one... ;)


Comment 6 Anne (:annevk) 2005-03-17 00:36:07 PST
Perhaps the path can be made an entity? And somehow be created when
Firefox/Mozilla/Netscape is installed.
Comment 7 Stefan [:stefanh] (away until May 28) 2005-03-20 13:23:48 PST
(In reply to comment #6)
> Perhaps the path can be made an entity? And somehow be created when
> Firefox/Mozilla/Netscape is installed.

We could do that. Any distributor could then change the path. We still have the
problem that paths are different between platforms/systems, though.
Comment 8 Anne (:annevk) 2005-03-21 00:45:20 PST
Well, isn't there an option to make a platform specific entity?
Comment 9 Giacomo Magnini 2005-12-07 10:02:23 PST
Created attachment 205230 [details] [diff] [review]
Fix for a few errors.

Since this bug has been somewhat fixed (by removing nab2 import which is not available in SM), I will reuse this nice summary for fixing other bugs! :)
Included in the patch is also the fix for bug 314966: please forget about it, but check carefully the rest.
Comment 10 Ian Neal 2005-12-08 14:41:06 PST
Comment on attachment 205230 [details] [diff] [review]
Fix for a few errors.

>Index: extensions/help/resources/locale/en-US/mail_help.xhtml
>===================================================================
>   <li><strong>Spellcheck As You Type:</strong> Choose this option to have the
>     spelling of the message text checked as you type.</li>
>+  <li><strong>Quote Message:</strong> Choose this option to have the
>+    selection of the message text shown as quoted text.</li>
"selection" could go on the previous line here, r= with that change.
Comment 11 Stefan [:stefanh] (away until May 28) 2005-12-08 15:07:50 PST
Giacomo, all this stuff is also good for branch, right?
Comment 12 Giacomo Magnini 2005-12-08 15:11:38 PST
(In reply to comment #11)
> Giacomo, all this stuff is also good for branch, right?

Very good, actually. It makes the docs for mailnews less uncomplete... ;)
Comment 13 Giacomo Magnini 2005-12-08 15:30:36 PST
Created attachment 205345 [details] [diff] [review]
Updated per comments and checkins... ;) (Checked into trunk/branch)
Comment 14 Giacomo Magnini 2005-12-08 15:54:08 PST
Comment on attachment 205345 [details] [diff] [review]
Updated per comments and checkins... ;) (Checked into trunk/branch)

Carrying over r+, waiting for checkin.
Comment 15 Ian Neal 2005-12-08 16:40:13 PST
Comment on attachment 205345 [details] [diff] [review]
Updated per comments and checkins... ;) (Checked into trunk/branch)

Checking in
mail_help.xhtml;
new revision: 1.66; previous revision: 1.65
done
Comment 16 Stefan [:stefanh] (away until May 28) 2005-12-08 23:36:52 PST
--> Fixed
Comment 17 Stefan [:stefanh] (away until May 28) 2005-12-08 23:37:38 PST
Comment on attachment 205345 [details] [diff] [review]
Updated per comments and checkins... ;) (Checked into trunk/branch)

Low-risk, SeaMonkey Help only...
Comment 18 Stefan [:stefanh] (away until May 28) 2005-12-09 09:12:55 PST
Moving to suite component in order to set flag...
Comment 19 Stefan [:stefanh] (away until May 28) 2005-12-09 09:14:27 PST
Comment on attachment 205345 [details] [diff] [review]
Updated per comments and checkins... ;) (Checked into trunk/branch)

Low-risk, SeaMonkey Help...
Comment 20 Ian Neal 2005-12-09 15:18:55 PST
Comment on attachment 205345 [details] [diff] [review]
Updated per comments and checkins... ;) (Checked into trunk/branch)

a=me, just need one more now...

Note You need to log in before you can comment on or make changes to this bug.