If two SELECT boxes are on top of each other by position: absolute, only one of them can be clicked

RESOLVED DUPLICATE of bug 102695

Status

()

RESOLVED DUPLICATE of bug 102695
14 years ago
14 years ago

People

(Reporter: yuliangr, Assigned: bugzilla)

Tracking

({testcase})

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0

The setup is that I have two TABLEs that are style="position:absolute"    so
they are resting on top of each other. Inside each TABLE, I have a <tr><td> and
then a SELECT box inside the <td>.       I activate one SELECT and deactivate
the other by using Javascript on the TABLE    style.visibility=visible or hidden 

When I have table1 (arbitrary numbering)  visible and table2 hidden, you can
select options just fine.

When I have table2 visible and table1 hidden, you cannot select options (with
catch).

I played around with it and discovered something else.   Table2 because of the
select options inside is about 50pixels wider than Table1.   When table2 is
visible, if you click on the right side of the option, you can succesfully
select the option.   However if you click on the majority of the option text, it
won't select.   It looked like the cutoff line between succcess and failure was
right at the line where the smaller select box ended.  

Reproducible: Always

Steps to Reproduce:
see details

Actual Results:  
see details

Expected Results:  
see details

Comment 1

14 years ago
Please make a small testcase and attach it to the bug using this link:
https://bugzilla.mozilla.org/attachment.cgi?bugid=283386&action=enter
(Reporter)

Comment 2

14 years ago
Created attachment 175447 [details]
typeA/B makes one of the bottom select box  visible/ other is hidden
-> NEW
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: testcase

Comment 4

14 years ago
It doesnt work because there is a hidden table above it. 

*** This bug has been marked as a duplicate of 102695 ***
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.