Add prefs UI for option to disable (don't show) the new-message tray icon

RESOLVED FIXED in Thunderbird 22.0

Status

Thunderbird
Preferences
--
enhancement
RESOLVED FIXED
13 years ago
4 years ago

People

(Reporter: Florian Effenberger, Assigned: Javi Rueda)

Tracking

Trunk
Thunderbird 22.0
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments, 1 obsolete attachment)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; de-DE; rv:1.7.5) Gecko/20041108 Firefox/1.0
Build Identifier: Thunderbird 1.0

I would like to see an option to disable the new message tray icon.

Reproducible: Always

Comment 1

13 years ago
I believe there is a bug for this filed against the suite, but I'm not having 
any luck finding it.  Not that I'd dupe this to that one; notification issues 
appear to be product-specific.

This applies to Mac as well as Windows, I guess, but *nix doesn't have a tray.

If this tray icon is suppressed, do you still expect to be able to see the new 
message alert slider/popup?
Summary: option to disable the new message tray icon → option to disable (don't show) the new message tray icon
(Reporter)

Comment 2

13 years ago
I can disable the slider (gray box with green or blue border and number of
messages) that shows up with

user_pref("alerts.totalOpenTime", 0);

but I cannot disable the icon in the systray (white envelope with green arrow).
I would like to disable that one as well.
(Reporter)

Comment 3

13 years ago
Attached is a screenshot of how this systray icon I want to disable looks like.
(Reporter)

Comment 4

13 years ago
Created attachment 175438 [details]
screenshot of how this systray icon I want to disable looks like

Comment 5

13 years ago
Seamonkey bug 133917.
(Reporter)

Comment 6

13 years ago
I tried

user_pref("mail.server.default.notify.on",false);

but it has NO effect in TB 1.0.
This is an automated message, with ID "auto-resolve01".

This bug has had no comments for a long time. Statistically, we have found that
bug reports that have not been confirmed by a second user after three months are
highly unlikely to be the source of a fix to the code.

While your input is very important to us, our resources are limited and so we
are asking for your help in focussing our efforts. If you can still reproduce
this problem in the latest version of the product (see below for how to obtain a
copy) or, for feature requests, if it's not present in the latest version and
you still believe we should implement it, please visit the URL of this bug
(given at the top of this mail) and add a comment to that effect, giving more
reproduction information if you have it.

If it is not a problem any longer, you need take no action. If this bug is not
changed in any way in the next two weeks, it will be automatically resolved.
Thank you for your help in this matter.

The latest beta releases can be obtained from:
Firefox:     http://www.mozilla.org/projects/firefox/
Thunderbird: http://www.mozilla.org/products/thunderbird/releases/1.5beta1.html
Seamonkey:   http://www.mozilla.org/projects/seamonkey/

Comment 8

12 years ago
*** Bug 310600 has been marked as a duplicate of this bug. ***

Updated

12 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 9

12 years ago
Bug 310600 isn't exactly a duplicate but I guess it can be fixed at the same time.

I don't think an extra option should be included in the preferences but I'm of
the opinion that the "Show an alert" option should prevent the systemtray icon
and the popup from appearing. Both are alerts and by disabling the "Show an
alert" option I expect both alerts to stay away.
Some tweakers might prefer to have the option to show just one of both alerts
but I think this won't be the case for the majority of the users. Because of
this I think we shouldn't clutter the UI with yet another option. An extra
option for the tweaker could always be provided in the the about:config way.

Comment 10

11 years ago
Bug 133917 has added the backend support necessary for this feature, on the trunk (targeted for TB 3.0).  Setting this preference to False:
  mail.biff.show_tray_icon
will suppress the icon.  In TB, using a current 3a1 build, you can do this 
using:   Options | Advanced | Config Editor.

This bug is now about adding a checkbox in the Options dialog for the feature, altho that may be WontFix'd.
Summary: option to disable (don't show) the new message tray icon → Add prefs UI for option to disable (don't show) the new-message tray icon
Version: unspecified → Trunk
dup of bug 360030?

Comment 12

11 years ago
(In reply to comment #11)
> dup of bug 360030?

No, that didn't provide a checkbox to en/disable the tray icon.

Comment 13

11 years ago
Can the procedure be re-started for this request?  I still don't like the icon! :)

Comment 14

11 years ago
(In reply to comment #13)
> Can the procedure be re-started for this request?  I still don't like
> the icon!

See comment 10.  That feature was checked in to the trunk as well, so it's available in 2b1; you just have to set the pref via the Config Editor rather than having an explicit checkbox.

Updated

11 years ago
Duplicate of this bug: 369892

Updated

10 years ago
Duplicate of this bug: 376718
QA Contact: preferences

Comment 17

10 years ago
Are there plans to add that checkbox (in v2b1) to the actual UI or should I create a request for that?
This is actually a request. Further Thunderbird 2 is released and no new features will be implemented, especially none which result in l10 changes. If someone creates a patch it could come with Thunderbird 3.

Updated

9 years ago
Assignee: mscott → nobody
(Assignee)

Updated

5 years ago
Assignee: nobody → leofigueres
(Assignee)

Comment 19

5 years ago
Created attachment 694397 [details]
Screenshot with the new checkbox added.
(Assignee)

Comment 20

5 years ago
Created attachment 694400 [details] [diff] [review]
patch

Mainly I copied most of the code used in the suite edition of this bug.

I just add a new checkbox to enable or disable the icon on the notification area only on Windows.

Tested on Windows 7.
Attachment #694400 - Flags: review?(bwinton)
Comment on attachment 694400 [details] [diff] [review]
patch

>+++ b/mail/components/preferences/general.xul
>@@ -63,16 +66,21 @@
>+#ifdef XP_WIN
>+      <checkbox id="newMailNotificationTrayIcon" label="&showTrayIcon.label;"
>+              preference="mail.biff.show_tray_icon"
>+              accesskey="&showTrayIcon.accesskey;" />
>+#endif

I think it would be better for addons to always have the checkbox there, but add hidden="true" if we're not on Windows…

Other than that, it seems good to me, so r=me with that fixed.
(And I'm going to go ahead and give it a ui-r=me, while I'm here.  Normally I'm against adding checkboxes for stuff most people won't use, but for some reason I'm feeling generous today…  ;)

Thanks, and I apologize for the length of time it took me to get to this review!

Later,
Blake.
Attachment #694400 - Flags: ui-review+
Attachment #694400 - Flags: review?(bwinton)
Attachment #694400 - Flags: review+
(Assignee)

Comment 22

4 years ago
Sorry for the delay. I have been really busy on my everyday job.

Today I am going to make needed change and re-attach it so someone could check-in on the tree.

Thank you for your review, Blake :-)
(Assignee)

Comment 23

4 years ago
Created attachment 728634 [details] [diff] [review]
patch with correction

will show a checkbox to disable the icon for new messages on the notification area on windows.

The UI will be available on all OS but only visible on windows.
Attachment #694400 - Attachment is obsolete: true
(Assignee)

Updated

4 years ago
Keywords: checkin-needed
https://hg.mozilla.org/comm-central/rev/4755900e012e

Thanks for the patch.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 22.0
You need to log in before you can comment on or make changes to this bug.