Cannot move de-junked mail from local Junk folder back to IMAP folder.

RESOLVED WORKSFORME

Status

RESOLVED WORKSFORME
14 years ago
10 years ago

People

(Reporter: joris, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5) Gecko/20041217
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5) Gecko/20041217

When I mark a 'false alarm' Junk message in "local folders.Junk mail" as Not
Junk, and then attempt to move the message back onto an IMAP folder, a dialog
box opens with the following text:
"The current command did not succeed. The mail server responded: Message
contains invalid header."
Problem doesn't occur when Junk Mail folder is placed on IMAP server.

Reproducible: Always

Steps to Reproduce:
1.Use IMAP mail account
2.Configure junk filter to move messages marked as Junk into a Local Folders
Junk Mail folder
3.Wait for/Make the filter mark a message as junk (so it's moved into the Local
Folders Junk mail Folder)
4.Go to Junk Mail folder (on Local Folders)
5.Mark the junked message as Not Junk
5.Move the message to Inbox on IMAP server

Actual Results:  
Dialog box appears with "The current command did not succeed. The mail server
responded: Message contains invalid header." 
The message is not moved.

Expected Results:  
Mozilla should have moved the message into the selected IMAP folder.

Problem does not occur when Junk Mail folder is placed on IMAP server.
Theme used: default theme.

Updated

14 years ago
Version: unspecified → 1.7 Branch

Comment 1

14 years ago
bienvenu: You have a idea what's going on here? I couldn't find a similar bug
report about this so far.
I can reproduce this on thunderbird trunk 20050313. The beginning of an
offending message in the Local Folders/Junk mbox looks like this:

From - Mon Apr 04 22:33:13 2005
X-Mozilla-Status: 0001
X-Mozilla-Status2: 00000000
>From - Mon Apr  4 22:33:08 2005
X-Mozilla-Status: 0001
X-Mozilla-Status2: 00000000

I'm not sure how to reproduce it quite deterministically -- occasionally the
filtered messages aren't marked as junk when they land in local/junk! -- but
setting "When I manually mark" to "Junk folder" using the Local Folders Junk
folder as the target in the adjacent bit, then marking messages as junk on imap
and perhaps back on local, and trying to move them back to imap does get there
pretty fast.
Status: UNCONFIRMED → NEW
Component: MailNews: Main Mail Window → MailNews: Filters
Ever confirmed: true
OS: Windows XP → All
Product: Mozilla Application Suite → Core
Version: 1.7 Branch → Trunk

Comment 3

14 years ago
Related to bug 249472 or bug 158014?
sorry for the spam.  making bugzilla reflect reality as I'm not working on these bugs.  filter on FOOBARCHEESE to remove these in bulk.
Assignee: sspitzer → nobody
(In reply to comment #2)
> From - Mon Apr 04 22:33:13 2005
> X-Mozilla-Status: 0001
> X-Mozilla-Status2: 00000000
> >From - Mon Apr  4 22:33:08 2005
> X-Mozilla-Status: 0001
> X-Mozilla-Status2: 00000000

To Tuukka Tolvanen:
As you already know, your problem is being analyzed in Bug 295672.  
To Joris(bug opener):

Are you still experiencing original problem in Comment #0?
If yes, is your case ">From - ..." case?
Or other case such as "LF" only line case?
To what mail header, was error message of "Message contains invalid header" returned from IMAP server?
Can you attach mail data which produces original error in Comment #0?

If you don't see original problem any more, close as WORKSFORME(or INVALID), please.
If you can't re-produce original problem, or you can't provide sufficient data, close as INCOMPLETE, please.

Updated

10 years ago
QA Contact: filters
(Assignee)

Updated

10 years ago
Product: Core → MailNews Core

Comment 7

10 years ago
Assuming wada's implying this should be gone.
i can't reproduce, and no response from reporter, so 
=> WFM
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.