Message Filters dialog not consistently initialized with correct account

RESOLVED WORKSFORME

Status

Thunderbird
Mail Window Front End
--
minor
RESOLVED WORKSFORME
13 years ago
12 years ago

People

(Reporter: Mike Cowperthwaite, Assigned: Scott MacGregor)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
I encountered this while investigating bug 279935.

Normally, Tools|Message Filters opens the dialog with the account dropdown set 
to match the currently selected item -- be it an account, a folder or a message.

However, this is not consistent for Local Folders.  Once a single *message* has 
been selected in the Thread pane, opening the Message Filters dialog opens with 
the default account selected instead.

My config includes a several POP accounts, one of which is the default and none 
of which are deferred to the Local Folders or another POP account, and an IMAP.

Steps to reproduce:
1) Select a folder in Local Folders;
   Open Message Filters, observe selected account
2) Close filters window; Select a message in the folder;
   Open Message Filters, observe selected account

Actual results:
After (1), Local Folders is the selected account
After (2), default account is the selected account

I see this with TB 1.0 and 1.0+0222 (trunk), but not in Moz 1.8b-0120.

This may be the same as bug 229485, but I cannot reproduce that bug as 
described.
(Reporter)

Comment 1

13 years ago
Also note: I normally have "Remember last selected message" turned off, which 
allows me to select a Local Folder without having a message selected.  When I 
turn it on, going to a folder with a remembered message causes the default 
account to be selected, just as if I'd explicitly clicked on the message.

If a single message is in the folder, Ctrl-A also behaves as if a message had 
been clicked.

Problem occurs even if message pane is hidden.

Comment 2

13 years ago
(In reply to comment #2)
> (In reply to comment #0)
> > Steps to Reproduce:
> > 1. I create a new message filter for Local Folders by clicking the context
> > menu icon in an email
> 
> This email message is *in* a Local Folder, right?

Yes, the email message is in a Local Folder.

> 
> > 3. I press OK. Also appears to be good. I choose Tools>Message Filters... to
> > open the Message Filters Dialog.
> > 4. The message filter I just created does not appear.
> 
> Which account is shown in the Message Filters dialog when it opens?  I am seeing 
> confusing behavior here; per bug 283476, the Local Folders account is *not* 
> selected in the dropdown, if a message in the Local Folders has been selected.
>

When I view the Message Filters dialog, I first (always) select Local Folders
from the pop-up list . When I reopen the Message Filters dialog, I would expect
the Local Folders selection to be highlighted and the Local Folders filters to
be displayed in the Filters list. In other words, I would expect the selected
option from the pop-up list to "stick" and to display the appropriate message
filters based on the last option selected.
 
> 
> > Expected Results:  
> > When a message filter is created and you press OK to finish creating the
> > message filter, the message filter list should be refreshed automatically
> 
> I get these expected results with TB 1.0, Win2K.  In fact, if you keep the 
> Message Filters window open, and use Create Filter From Message on a message in 
> the same account, once you click OK the list dynamically refreshes.
> 
> Reporter (Prefix) -- does this description match what you see with TB 1.0 / Mac?
> If so, can you reproduce bug 283476 on the Mac?
>

I do not currently have the software to test whether this bug is reproduceable
using TB on the Mac. I DO however, have an iMac G5 and am using Thunderbird 1.1
on Mac OS X 10.3.8. The refresh DOES occur correctly, but I still need to
reselect "Local Folders" from the pop-up list to view the list of folders every
time I open the Message Filters dialog. 
 
> 
> (In reply to comment #1)
> > I have had trouble getting filters to stay in the list.  I select a message,
> > and create a filter from the message.  I then test the new filter by running
> > it. 
> > Yes, it moves the message successfully.  But sometimes when I next launch
> > Thunderbird, the filter has disappeared.
> 
> This is bug 277189.

(Reporter)

Comment 3

13 years ago
Comment 2 should have been posted in bug 279935 -- but he does conveniently note 
that this bug occurs on a trunk build of TB on the Mac, so updating platform.
OS: Windows 2000 → All
Hardware: PC → All
(Reporter)

Comment 4

13 years ago
I think I've gotten a better handle on this behavior.  If a (mail) message is 
selected when the Message Filters dialog is opened, the selected account is the 
account to which the message was sent -- perhaps taken from the X-Account-Key 
header.  If no message is selected, or if the message does not have an 
X-Account-Key header (e.g, copied from a newsgroup or RSS feed), the Message 
Filters dialog is initialized per the account (or folder) selected in the Folder 
Pane.

Comment 5

13 years ago
(In reply to comment #4)
> I think I've gotten a better handle on this behavior.  If a (mail) message is 
> selected when the Message Filters dialog is opened, the selected account is the 
> account to which the message was sent -- perhaps taken from the X-Account-Key 
> header.  If no message is selected, or if the message does not have an 
> X-Account-Key header (e.g, copied from a newsgroup or RSS feed), the Message 
> Filters dialog is initialized per the account (or folder) selected in the Folder 
> Pane.

I just tested what I think you are explaining on iMac G5 Mac OS 10.3.8, TB
1.0.2. It sounds like you are saying that based on the selected email (and its
account), that is the selection in the Message Filter drop down list and then
those are the filters that are displayed.

If I am interpreting this correctly, then my testing does not agree.
I have multiple accounts but find it faster to get/reply/access all mail using
Local Folders - rather than switching back and forth from accounts.

Regardless of which email is selected (and its respective account), the
selection in the drop down is ALWAYS the first account created, and the message
filter list that displays is for that account. EVERYTIME, that I open Message
Filters, I MUST choose "Local Folders" in order to view/edit the Local Folders
message filters.

Please let me know if my understanding (of your comments) is correct and of
course, if upgrading to a newer version of TB is warranted (i.e. the bug has
been resolved), I will be happy to hear that as well.

(Reporter)

Comment 6

13 years ago
(In reply to comment #5)
> Regardless of which email is selected (and its respective account), the
> selection in the drop down is ALWAYS the first account created, and the
> message filter list that displays is for that account. 

Suppose I have two messages in my Local Folders Inbox, one that originally was 
sent to account A (default/first-created) and the other to account B:  if I 
select the first message and then Tools | Message Filters, the dialog's account 
dropdown is initialized to account A; and if I select the second message and 
then Tools | Message Filters, the dialog's account dropdown is initialized to 
account B.

> EVERYTIME, that I open Message Filters, I MUST choose "Local Folders" in
> order to view/edit the Local Folders message filters.

If I select neither message (which requires turning off the option "Remember the 
last selected message"), but have selected the Local Folders Inbox, then when I 
select Tools | Message Filters, the dialog's dropdown is initialized to Local 
Folders.

I see these results with TB 1.0.2 and with TB 1.0+0428, Win2K.  I think it's 
unlikely that the Mac version behaves differently in this regard.
(Reporter)

Comment 7

12 years ago
(In reply to comment #6)
> > EVERYTIME, that I open Message Filters, I MUST choose "Local Folders" in
> > order to view/edit the Local Folders message filters.
> 
> If I select neither message (which requires turning off the option "Remember
> the last selected message"), but have selected the Local Folders Inbox, then
> when I select Tools | Message Filters, the dialog's dropdown is initialized
> to Local Folders.

I think I have found the point of disagreement here: as noted in the original 
report, none of my POP accounts use the global inbox.

I tested with a deferred account, and in *this* case, when the Local Folders 
Inbox is selected, the Message Filters window opens with the deferred account 
selected in the dropdown.  Also, if a non-account message (e.g. a newsgroup 
posting) is selected within the Local Folders inbox, the Message Filters window 
opens to the deferred account.
(Reporter)

Comment 8

12 years ago
(In reply to comment #7)
> I tested with a deferred account, and in *this* case, when the Local Folders 
> Inbox is selected, the Message Filters window opens with the deferred account 
> selected in the dropdown.  Also, if a non-account message (e.g. a newsgroup 
> posting) is selected within the Local Folders inbox, the Message Filters
> window opens to the deferred account.

Addendum: This is true if the *default* account is deferred to L.F.  If the 
default account stands alone, but other accounts are deferred, the message 
filters window opens to Local Folders when the folder (or a no-account msg) is 
selected.


I'm closing this as WFM because it seems to behave consistently: 
 - if a message is selected, the filters window opens to that message's account.
 - if no message is selected, the filters window opens to the folder's account.

The "folder's account" is either: the actual account containing the folder, or 
(for a Local Folder when the default account is deferred to the global inbox) 
the default account, or (for a Local Folder when the default account is not 
deferred) Local Folders.
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → WORKSFORME
Summary: Message Filters dialog not consistently initialized for Local Folders → Message Filters dialog not consistently initialized with correct account
You need to log in before you can comment on or make changes to this bug.