.msf is rebuild everytime user changes OS platforms

RESOLVED DUPLICATE of bug 232047

Status

MailNews Core
Database
RESOLVED DUPLICATE of bug 232047
13 years ago
10 years ago

People

(Reporter: Duke Windsor, Assigned: Bienvenu)

Tracking

1.7 Branch
All
Linux

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.2) Gecko/20030208 Netscape/7.02
Build Identifier: Thunderbird .9x

In linux, the mail summary files use a LF character as the end of record.
In Windows XP, the mail summary files use CRLF characters as the end of record.
When the mail folders reside on a file server (linux), allowing access from both
platforms (via samba), the .smf files are rebuild when the user changes
platforms. That is - if the user has been reading his mail from an XP client,
when he changes to a linux machine and reads his mail, the .smf files are
rebuilt.  The .smf files created by both OS's are identical except for the
end-of-record character(s). Thunderbird on the most resent OS considers the
files corrupted and rebuilds them. 

Reproducible: Always

Steps to Reproduce:
1. Configure Thunderbird to move mail from the server to a local directory on linux.
2. Samba share this directory and map it to a windows XP machine
3. Configure Thunderbird on the Windows machine the same as linux.
4. read mail on one platform
5. change to the other OS and access mail.  The .msf is rebuilt.  The two .msf
files (the linux version and the XP version) are identicle except for the
character terminating each line.  LF for linux and CRLF for XP.  If the 
end-of-record were the same on both platforms, the user could read his mail
on a shared directory from either OS.



Expected Results:  
expected the two installations to create identicle mail summary files
Assignee: mscott → bienvenu
Component: General → MailNews: Database
Product: Thunderbird → Core
Version: unspecified → 1.7 Branch
(Assignee)

Comment 1

13 years ago
I don't believe this has to do with the line endings. I believe it has to do
with the two OS's reporting slightly different timestamps for the mail folder
itself, one of which doesn't match the timestamp stored in the db. You can set a
hidden pref in your user.js, e.g., user_pref("mail.db_timestamp_leeway", 10); to
make the db more tolerant of slight deltas in the timestamps due to file system
differences. In this example, the leeway would be 10 seconds.
This is an automated message, with ID "auto-resolve01".

This bug has had no comments for a long time. Statistically, we have found that
bug reports that have not been confirmed by a second user after three months are
highly unlikely to be the source of a fix to the code.

While your input is very important to us, our resources are limited and so we
are asking for your help in focussing our efforts. If you can still reproduce
this problem in the latest version of the product (see below for how to obtain a
copy) or, for feature requests, if it's not present in the latest version and
you still believe we should implement it, please visit the URL of this bug
(given at the top of this mail) and add a comment to that effect, giving more
reproduction information if you have it.

If it is not a problem any longer, you need take no action. If this bug is not
changed in any way in the next two weeks, it will be automatically resolved.
Thank you for your help in this matter.

The latest beta releases can be obtained from:
Firefox:     http://www.mozilla.org/projects/firefox/
Thunderbird: http://www.mozilla.org/products/thunderbird/releases/1.5beta1.html
Seamonkey:   http://www.mozilla.org/projects/seamonkey/

Updated

11 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 232047
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.