All users were logged out of Bugzilla on October 13th, 2018

Location History Not Useful

RESOLVED DUPLICATE of bug 130429

Status

()

RESOLVED DUPLICATE of bug 130429
14 years ago
12 years ago

People

(Reporter: tcorbet, Assigned: bugs)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.6) Gecko/20050223 Firefox/1.0.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.6) Gecko/20050223 Firefox/1.0.1

I'd be rather certain that this behavior has been reported by other users, but
no combination of keyword search seems to locate the problem as I would describe it.

The best example of what is wrong is found by browsing Javadoc for the JDK.  If
you visit some Class, then navigate to some Super Class or some See Also Class,
because the pages all have Frames, and because your code evidently extracts the
<Title> from the "top", not the "main" Frame, the history of locations proves
useless.  All the Prior Page descriptions will be the same; there will be no
visual discrimination of what 'tracks' were actually visited.

I don't precisely know what heuristic tells you which <Title> tag to use in the
face of Frames, but somehow IE gets it right and Firefox doesn't.  Even if there
is no clear 'standard', please emulate the IE behavior so that we will have
usful history.

Thank you.

Reproducible: Always
This is really bug 130429, but also related is bug 211991.

*** This bug has been marked as a duplicate of 130429 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE

Updated

12 years ago
QA Contact: bugzilla → toolbars
(Reporter)

Comment 2

12 years ago
I'm not sure why Bugzilla decided to remind me, today, of this old item, but it's very nice that it did so.  It caused me to revisit the matter with FF 2.x, and now it works just fine.  Forward and Backward through the 'stack' of JDK docs leaves a perfect audit trail.

Thanks
You need to log in before you can comment on or make changes to this bug.