"New Card" created while displaying a "List" does not get added to list.

RESOLVED DUPLICATE of bug 117836

Status

SeaMonkey
MailNews: Address Book & Contacts
--
minor
RESOLVED DUPLICATE of bug 117836
13 years ago
13 years ago

People

(Reporter: Martin Crundall, Assigned: (not reading, please use seth@sspitzer.org instead))

Tracking

Trunk
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8a6) Gecko/20050111
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8a6) Gecko/20050111

When I am viewing a list (list name is highlighted in left pane of address book
app, and list items appear in right pane), if I then click "New Card", fill it
out and click ok, it "appears" to have been added to the list that I am viewing.
 However, if I then set focus to some other list or to the "Personal Address
Book" and then set focus BACK to the list I was viewing, the new card is not on
the list.  The New Card IS, however, added to the "Personal Address Book."

Reproducible: Always

Steps to Reproduce:
0. Click on "Personal Address Book" in left pane -- ensure expansion diamond is
pointing down and all lists, if any, are shown.
1. Click "New List" - enter "My New List" as list name, "NewList" as nickname,
"My cool new list" as Description.  Click "OK"
2. Click on "My New List" list under "Personal Address Book"
3. Click on "New Card" -- enter "Fred" <tab> "Bloggs" <tabx3> "fblogs@blogs.net"
<tab>, then click ok.
4. Notice how "Fred Bloggs" card appears in right pain.
5. Click "Personal Address Book", then click "My New List".  Notice how card is
now gone.

Actual Results:  
Card is added to Personal Address Book but NOT to selected list.

Expected Results:  
The appearance of the "Fred Bloggs" card initially on the list gives one the
impression that he should have been added to both the "Personal Address Book"
AND to "My New List."

the "workaround" is to simply drag-n-drop the card from "Personal Address Book"
into "My New List" -- no valuable typing is lost.

Comment 1

13 years ago
Dupe of Bug 117836.

*** This bug has been marked as a duplicate of 117836 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
Version: unspecified → Trunk
You need to log in before you can comment on or make changes to this bug.