Error dialogs/Status bar do not honor network.IDN_show_punycode when set to true and network.enableIDN is set to false

RESOLVED WONTFIX

Status

()

RESOLVED WONTFIX
14 years ago
3 years ago

People

(Reporter: chiefaesthete, Unassigned)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.6) Gecko/20050223 Firefox/1.0.1
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.6) Gecko/20050223 Firefox/1.0.1

Error dialogs do not honor network.IDN_show_punycode preference when
network.enableIDN is set to false. (Error dialogs operate as expected with
network.enableIDN set to true.)

Reproducible: Always

Steps to Reproduce:
1. Go to http://secunia.com/multiple_browsers_idn_spoofing_test/
2. Click the link "Test Now - Left Click On This Link"
3. Look at the resulting error dialog

Actual Results:  
The dialog reads: "www.paypаl.com could not be found. Please check the name and
try again."

Expected Results:  
"www.paypаl.com" should have been converted to Punycode, despite the fact that
IDN is disabled.
Also note that in this case (when network.enableIDN is false) the status line
reads www.payp%D0%B0l.com, instead of punycode. This garbage confuses users, and
it means nothing. Please, either convert it to punycode or leave it unicoded.
Hex is ugly when outside of debug window.
I suspect this is invalid, but -> Darin to be sure.

understanding and converting to punycode is a function of IDN. If IDN is off
then the code that would convert to punycode is off, and you're left with a host
with invalid non-ascii characters in the name and get any errors based on raw
processing of that.

The status bar sounds OK too. If IDN is off there is again no code to convert to
punycode. We're treating the host as-is, and without IDN support host names are
just strings of characters. The status bar reflects our understanding of the
hostname in the absense of IDN support, and how the host will be sent down the wire.
Assignee: firefox → darin
Component: General → Networking
Product: Firefox → Core
QA Contact: general → benc
Version: unspecified → 1.0 Branch

Comment 3

14 years ago
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8b2) Gecko/20050325 Firefox/1.0+

(In reply to comment #0)

Status -> NEW

With network.enableIDN == false && network.IDN_show_punycode == true error
dialogues and error pages ignore the punycode setting. I believe that punycode
should be displayed even if IDN is disabled (see bug 286890 .)
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 4

14 years ago
Disabling IDN means that we also disable the function to convert from IDN to
punycode.  Disabling IDN is not the default configuration, and I don't see this
as an important configuration to support.  Why is this important?  I'll probably
mark this WONTFIX unless there is a compelling reason to support this configuration.

Comment 5

14 years ago
*** Bug 286890 has been marked as a duplicate of this bug. ***

Comment 6

14 years ago
Updating Summary, otherwise feel free to correct it if I'm wrong.
Summary: Error dialogs do not honor network.IDN_show_punycode preference when network.enableIDN is set to false → Error dialogs/Status bar do not honor network.IDN_show_punycode when set to true and network.enableIDN is set to false

Updated

13 years ago
Assignee: darin → nobody
QA Contact: benc → networking
Version: 1.0 Branch → Trunk
comment 4
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.