Can't open Find as you Type/Find Toolbar

RESOLVED FIXED

Status

()

Toolkit
Find Toolbar
--
major
RESOLVED FIXED
13 years ago
10 years ago

People

(Reporter: Ger Teunis, Assigned: Blake Ross)

Tracking

({regression})

Trunk
x86
Windows XP
regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b2) Gecko/20050225 Firefox/1.0+
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b2) Gecko/20050225 Firefox/1.0+

Can't open Find as you Type/Find Toolbar using keyboard (' or / or CTRL-F) 
or Menu items (Edit -> Find in this page).


Reproducible: Always

Steps to Reproduce:
1. Try opening Find as you Type/Find Toolbar
2.
3.

Actual Results:  
Nothing happens.

Expected Results:  
The Find as you Type/Find Toolbar should popup.
->NEW
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 2

13 years ago
Javascript Console:

Error: bundle has no properties
Source File: chrome://global/content/findBar.js
Line: 244

Updated

13 years ago
Flags: blocking-aviary1.1?

Comment 3

13 years ago
*** Bug 283643 has been marked as a duplicate of this bug. ***

Updated

13 years ago
Severity: normal → major
Keywords: regression

Comment 4

13 years ago
Line 244 of chrome://global/content/findBar.js maps to
http://lxr.mozilla.org/seamonkey/source/toolkit/components/typeaheadfind/content/findBar.js#279

The stringbundle bundle_findBar was removed by the checkins of the new Prefs
window
http://bonsai.mozilla.org/cvsview2.cgi?diff_mode=context&whitespace_mode=show&subdir=mozilla/browser/base/content&command=DIFF_FRAMESET&file=browser-sets.inc&rev1=1.35&rev2=1.36&root=/cvsroot,
I'm not sure if the right fix is to add the stringbundle back or to change the
findBar.js code.

I  hope this is helpful to someone.

Comment 5

13 years ago
Created attachment 175565 [details] [diff] [review]
Use bundle_browser

Looking at the checking, I guessed bundle_findBar was removed because it really
was the same as bundle_browser, so I guess this is the right fix for this bug.
I'm not all that sure though, and it is my first patch ever, so I might be
completely wrong.
(In reply to comment #5)
> Looking at the checking, I guessed bundle_findBar was removed because it really
> was the same as bundle_browser, so I guess this is the right fix for this bug.
> I'm not all that sure though, and it is my first patch ever, so I might be
> completely wrong.

I came to the same conclusion and this patch does fix this bug.
Depends on: 274712
Whiteboard: [have patch]
*** Bug 283648 has been marked as a duplicate of this bug. ***
(In reply to comment #5)

> Looking at the checking, I guessed bundle_findBar was removed because it really
> was the same as bundle_browser, so I guess this is the right fix for this bug.

This introduces a toolkit dependency upon browser code.  The toolkit is supposed
to be self-sufficient -- it shouldn't depend upon Seamonkey code, Thunderbird
code, or Firefox code.  This patch makes toolkit depend upon Firefox code, so it
isn't likely to be r+'d.  You should change the patch to use bundle_findBar
again, because then toolkit is more self-contained and your patch is more likely
to be approved.
Fixed. 
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → FIXED
No longer depends on: 274712
Flags: blocking-aviary1.1?
Whiteboard: [have patch]

Comment 10

13 years ago
*** Bug 283783 has been marked as a duplicate of this bug. ***
*** Bug 284056 has been marked as a duplicate of this bug. ***

Comment 12

13 years ago
*** Bug 284285 has been marked as a duplicate of this bug. ***
*** Bug 326473 has been marked as a duplicate of this bug. ***
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.