Composing a mail or replying to one doesn't work

RESOLVED FIXED in mozilla1.8beta2

Status

()

Core
Editor
--
blocker
RESOLVED FIXED
13 years ago
13 years ago

People

(Reporter: mcsmurf, Assigned: neil@parkwaycc.co.uk)

Tracking

({regression, smoketest})

Trunk
mozilla1.8beta2
regression, smoketest
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments, 1 obsolete attachment)

(Reporter)

Description

13 years ago
With a current CVS trunk build (or a official nightly, here 2005-02-25-03) you
can't reply to a mail or compose a new mail. When you click Reply/Compose, it
opens the Compose window, but then you only get a busy mouse cursor over and
over again (the mouse cursor changes every few ms from normal to busy and back).
In the JS Console this error appears:
Error: [Exception... "Component returned failure code: 0x80004003
(NS_ERROR_INVALID_POINTER) [nsIMsgCompose.initEditor]"  nsresult: "0x80004003
(NS_ERROR_INVALID_POINTER)"  location: "JS frame ::
chrome://messenger/content/messengercompose/MsgComposeCommands.js ::
ComposeStartup :: line 1351"  data: no]
Source File: chrome://messenger/content/messengercompose/MsgComposeCommands.js
Line: 1351

This blocks smoketest M.1, M.2, M.4 and probably M.12, too.
(Assignee)

Comment 2

13 years ago
Created attachment 175549 [details] [diff] [review]
Proposed patch
Assignee: mozeditor → neil.parkwaycc.co.uk
Status: NEW → ASSIGNED
(Assignee)

Comment 3

13 years ago
Created attachment 175550 [details] [diff] [review]
Correct patch

Sorry, attached the wrong patch last time.
Attachment #175549 - Attachment is obsolete: true
(Assignee)

Comment 4

13 years ago
I got r+sr=bz on #developers
Status: ASSIGNED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → FIXED

Updated

13 years ago
OS: Windows 2000 → All
Hardware: PC → All
Created attachment 175558 [details] [diff] [review]
Make re-initializing the editor from code other than midas work again.

This may not be a problem with mailnews etc, but it is for some extensions that
use the editor. We end up re-initializing the editor, which ends up, in the
non-midas case, re-adding the editor as a web progress listener. That fails
(since it's already a listener) in nsEditingSession::PrepareForEditing(), which
ends up throwing an error, all the way back to the caller.
Attachment #175558 - Flags: superreview?(bzbarsky)
Attachment #175558 - Flags: review?(brade)

Comment 6

13 years ago
Comment on attachment 175558 [details] [diff] [review]
Make re-initializing the editor from code other than midas work again.

r=brade
Attachment #175558 - Flags: review?(brade) → review+
Comment on attachment 175558 [details] [diff] [review]
Make re-initializing the editor from code other than midas work again.

sr=bzbarsky
Attachment #175558 - Flags: superreview?(bzbarsky) → superreview+
(Assignee)

Comment 8

13 years ago
*** Bug 283705 has been marked as a duplicate of this bug. ***

Comment 9

13 years ago
*** Bug 283677 has been marked as a duplicate of this bug. ***
Keywords: mail4
Target Milestone: --- → mozilla1.8beta2
*** Bug 283821 has been marked as a duplicate of this bug. ***
Blocks: 283897
You need to log in before you can comment on or make changes to this bug.