Firefox .exe file reports incorrect version info

RESOLVED FIXED

Status

()

--
trivial
RESOLVED FIXED
14 years ago
7 years ago

People

(Reporter: m.ward, Assigned: chase)

Tracking

({fixed-aviary1.0.1})

unspecified
x86
Windows 2000
fixed-aviary1.0.1
Points:
---
Bug Flags:
blocking-aviary1.0.1 +

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.6) Gecko/20050223 Firefox/1.0.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.6) Gecko/20050223 Firefox/1.0.1

After installing Firefox 1.0.1, the version information for firefox.exe in
Windows Explorer still reports it the File Version as 1.0.0.0. and the product
version is reported as 1.7.5: 2004110711

Reproducible: Always

Steps to Reproduce:
1. Using Windows Explorer, browse to your firefox 1.0.1 installation folder.
2. Right click on firefox.exe and choose properties from the menu.
3. In the resultant dilaog, click on the version tab.
4. Read "File Version" or click Product Version on the list and read the value

Actual Results:  
Wrong version information.

Expected Results:  
File Version should read 1.0.1.0
Product version should read(?): 1.7.6: 20050223
Assignee: firefox → cmp
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 1

14 years ago
*** Bug 283652 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 2

14 years ago
Created attachment 175585 [details] [diff] [review]
Bump internal file versions for browser and mail

Still need to find where 1.7.5 / 2004110711 is coming from.  Not sure yet.
Attachment #175585 - Flags: superreview?(bryner)
Attachment #175585 - Flags: review?(dbaron)
Attachment #175585 - Flags: approval-aviary1.0.1?
(Assignee)

Comment 3

14 years ago
Comment on attachment 175585 [details] [diff] [review]
Bump internal file versions for browser and mail

release-checklist.html has been updated to include these files in the list of
required version bumps for the apps.  Should rebuild soon.
Comment on attachment 175585 [details] [diff] [review]
Bump internal file versions for browser and mail

r=dbaron, but please file a bug on getting this automated...
Attachment #175585 - Flags: review?(dbaron) → review+
(Although I guess it could also be part of bug 283218 if you comment there.)
Attachment #175585 - Flags: superreview?(bryner) → superreview+
(Assignee)

Comment 6

14 years ago
(In reply to comment #0)
> After installing Firefox 1.0.1, the version information for firefox.exe in
> Windows Explorer still reports it the File Version as 1.0.0.0. and the product
> version is reported as 1.7.5: 2004110711

Testing here we confirm the file version is incorrect.  When we look at the
product version, though, it reports as 1.7.6: 2005...  I wonder what's different
between the installations.
(Assignee)

Updated

14 years ago
Status: NEW → ASSIGNED
(Assignee)

Updated

14 years ago
Flags: blocking-aviary1.0.1+
Comment on attachment 175585 [details] [diff] [review]
Bump internal file versions for browser and mail

a=dveditz

Is that copyright correct? The source is tri-licensed, but the binary is
released only under one.
Attachment #175585 - Flags: approval-aviary1.0.1? → approval-aviary1.0.1+
(Assignee)

Comment 8

14 years ago
Comment on attachment 175585 [details] [diff] [review]
Bump internal file versions for browser and mail

Landed this on aviary-1.0.1 branch.

Checking in browser/app/module.ver;
/cvsroot/mozilla/browser/app/module.ver,v  <--	module.ver
new revision: 1.9.4.5.2.1; previous revision: 1.9.4.5
done
Checking in mail/app/module.ver;
/cvsroot/mozilla/mail/app/module.ver,v	<--  module.ver
new revision: 1.4.2.3.2.5.2.1; previous revision: 1.4.2.3.2.5
done
(Assignee)

Comment 9

14 years ago
When we verify that both the app version and product version are correct in a
newly spun build (say post drivers meeting), we should set fixed-aviary1.0.1.  I
don't think we should set it before then.
(Reporter)

Comment 10

14 years ago
(In reply to comment #6)
> Testing here we confirm the file version is incorrect.  When we look at the
> product version, though, it reports as 1.7.6: 2005...  I wonder what's different
> between the installations.

Confirming the same results with my home installation. It's not possible for me
to verify my work installation until Monday morning.
(Reporter)

Comment 11

14 years ago
(In reply to comment #10)
> Confirming the same results with my home installation. It's not possible for me
> to verify my work installation until Monday morning.

Re-installed and verified that the product version is in fact correct, but the
file version is incorrect.
(Assignee)

Comment 12

14 years ago
This was fixed for 1.0.1.  Retroactively marking as such.
Status: ASSIGNED → RESOLVED
Last Resolved: 14 years ago
Keywords: fixed-aviary1.0.1
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.