Closed Bug 283668 Opened 15 years ago Closed 15 years ago

Linked area can be too large in BiDi text

Categories

(Core :: Layout: Text and Fonts, defect)

defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 178991

People

(Reporter: tcdb, Assigned: mkaply)

References

()

Details

(Keywords: testcase)

Attachments

(1 file)

User-Agent:       Mozilla/4.8 [en] (Windows NT 5.1; U)
Build Identifier: v1.0

There are TWO link above the picture. Each on a word saying "HERE".
Only the second link is active.
And this link is activae all along the line, although it should
be confined to one word of the line.

Reproducible: Always

Steps to Reproduce:
1. call http://www.kamatz.org/English_Site/index.htm
2. See the second line above the picture. Say ... HERE and HERE
3. The link of the second HERE is active not only for that word, but for the
whole line. 
4. See source - there are two link there.

Actual Results:  
The whole line with the HERE words acts as a link to the 2nd HERE.
1st HERE not working. Other text also sensitive.

Expected Results:  
The 1st word HERE has a different link than the 2nd HERE.
Each should call a different page. Other words on the senctence 
should NOT call another page.
Removing style='direction:rtl' on the body element fixes this. I'll do a reduced
testcase.
Assignee: firefox → mkaply
Component: General → Layout: BiDi Hebrew & Arabic
OS: MacOS X → All
Product: Firefox → Core
QA Contact: general → zach
Hardware: Macintosh → All
Version: unspecified → Trunk
Attached file Reduced Testcase
Here's a reduced testcase. This relies on the presence of a <br> inside an <a>,
while the problem on original page didn't, but I don't think that affects much.


Problem occurs in both standards and quirks.
Could this perhaps be a dupe of bug 133567?
Keywords: testcase
Summary: Links not working properly → Linked area can be too large in BiDi text
No, but this is definitely a dup.
Whiteboard: DUPEME
Er... I mean bug 178991.

*** This bug has been marked as a duplicate of 178991 ***
Status: UNCONFIRMED → RESOLVED
Closed: 15 years ago
Resolution: --- → DUPLICATE
Component: Layout: BiDi Hebrew & Arabic → Layout: Text
QA Contact: zach → layout.fonts-and-text
Whiteboard: DUPEME
You need to log in before you can comment on or make changes to this bug.