Fx crashed on www.ictv.ua [@ PL_DHashTableRawRemove ]

RESOLVED DUPLICATE of bug 237736

Status

()

Firefox
General
--
critical
RESOLVED DUPLICATE of bug 237736
13 years ago
7 years ago

People

(Reporter: Evgeniy Sudyr, Assigned: Blake Ross)

Tracking

({crash})

Firefox Tracking Flags

(Not tracked)

Details

(crash signature, URL)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0

Program crash (with windows error report window) when I try browse site of
ukrainian TV company http://www.ictv.ua

Also I`m using proxy server (SQUID with Digest Auth) maybe it will help u.

Reproducible: Always
Please reinstall with talkback (choose a "custom" install, I think it's called a
Quality Reporting Tool or some such on that dialog). Since 1.0.1 is now released
you're probably going to install it anyway.

Then when you crash you will send stack traces to us. Run the talkback.exe and
it will show you a list of talkback ID's which you can put in this bug, and we
can look up to find out where it's crashing.

Comment 2

13 years ago
I agree: Firefox for Win32 build 20050224 does CRASH. I opted for a nighly of
the next day as:

 Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b2) Gecko/20050225
Firefox/1.0+

Anything I should change????

Updated

13 years ago
Keywords: crash
Summary: program crashed → Fx crashed on www.ictv.ua

Comment 3

13 years ago
Got a crash here too.  

Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8b2) Gecko/20050226
Firefox/1.0+

My talkback as per the first comment: TB3971806Z
(Reporter)

Comment 4

13 years ago
I can`t send u Report by reporting tool becouse it don`t support proxy server auth .
I`m behind proxy (at my university). Last build of firefox does crash too

Comment 5

13 years ago
TB3971806Z:
PL_DHashTableRawRemove 
[c:/builds/tinderbox/Fx-Trunk/WINNT_5.0_Depend/mozilla/xpcom/ds/pldhash.c, line 596]
nsGenericElement::~nsGenericElement 
[c:/builds/tinderbox/Fx-Trunk/WINNT_5.0_Depend/mozilla/content/base/src/nsGenericElement.cpp,
line 844]
Summary: Fx crashed on www.ictv.ua → Fx crashed on www.ictv.ua [@ PL_DHashTableRawRemove ]

Comment 6

13 years ago
A more complete stacktrace (but it was a different site so, i marked some text
on that site and maybe tried to perform some drag&drop operation):
PL_DHashTableRawRemove(PLDHashTable * 0x016b8644, PLDHashEntryHdr * 0x0607baa0)
line 596
PL_DHashTableOperate(PLDHashTable * 0x016b8644, const void * 0x05fd36f8, int
0x00000002) line 564
nsGenericElement::~nsGenericElement(nsGenericElement * const 0x0607baa0) line
844 + 13 bytes
nsHTMLAnchorElement::`scalar deleting destructor'(nsHTMLAnchorElement * const
0x0607baa0, unsigned int 0x00000001) + 8 bytes
nsHTMLIFrameElement::Release(nsHTMLIFrameElement * const 0x05fd36f8) line 92 +
27 bytes
nsAttrAndChildArray::Clear(nsAttrAndChildArray * const 0x0607baa0) line 621 + 6
bytes
nsAttrAndChildArray::~nsAttrAndChildArray(nsAttrAndChildArray * const
0x0607baa0) line 126
nsGenericElement::~nsGenericElement(nsGenericElement * const 0x0607baa0) line
854 + 8 bytes
nsHTMLUnknownElement::`scalar deleting destructor'(nsHTMLUnknownElement * const
0x0607baa0, unsigned int 0x00000001) + 8 bytes
nsHTMLIFrameElement::Release(nsHTMLIFrameElement * const 0x061f6ab8) line 92 +
27 bytes
nsAttrAndChildArray::Clear(nsAttrAndChildArray * const 0x0607baa0) line 621 + 6
bytes
nsAttrAndChildArray::~nsAttrAndChildArray(nsAttrAndChildArray * const
0x0607baa0) line 126
nsGenericElement::~nsGenericElement(nsGenericElement * const 0x0607baa0) line
854 + 8 bytes
nsHTMLFontElement::`scalar deleting destructor'(nsHTMLFontElement * const
0x0607baa0, unsigned int 0x00000001) + 8 bytes
nsHTMLIFrameElement::Release(nsHTMLIFrameElement * const 0x061f6a28) line 92 +
27 bytes
nsAttrAndChildArray::Clear(nsAttrAndChildArray * const 0x0607baa0) line 621 + 6
bytes
nsAttrAndChildArray::~nsAttrAndChildArray(nsAttrAndChildArray * const
0x0607baa0) line 126
nsGenericElement::~nsGenericElement(nsGenericElement * const 0x0607baa0) line
854 + 8 bytes
nsHTMLTableCellElement::`scalar deleting destructor'(nsHTMLTableCellElement *
const 0x0607baa0, unsigned int 0x00000001) + 8 bytes
nsHTMLIFrameElement::Release(nsHTMLIFrameElement * const 0x061f6938) line 92 +
27 bytes
nsAttrAndChildArray::Clear(nsAttrAndChildArray * const 0x0607baa0) line 621 + 6
bytes
nsAttrAndChildArray::~nsAttrAndChildArray(nsAttrAndChildArray * const
0x0607baa0) line 126
nsGenericElement::~nsGenericElement(nsGenericElement * const 0x0607baa0) line
854 + 8 bytes
nsHTMLTableRowElement::`scalar deleting destructor'(nsHTMLTableRowElement *
const 0x0607baa0, unsigned int 0x00000001) + 8 bytes
nsHTMLIFrameElement::Release(nsHTMLIFrameElement * const 0x061f6910) line 92 +
27 bytes
nsAttrAndChildArray::Clear(nsAttrAndChildArray * const 0x0607baa0) line 621 + 6
bytes
nsAttrAndChildArray::~nsAttrAndChildArray(nsAttrAndChildArray * const
0x0607baa0) line 126
nsGenericElement::~nsGenericElement(nsGenericElement * const 0x0607baa0) line
854 + 8 bytes
nsHTMLTableSectionElement::`scalar deleting
destructor'(nsHTMLTableSectionElement * const 0x0607baa0, unsigned int
0x00000001) + 8 bytes
nsHTMLIFrameElement::Release(nsHTMLIFrameElement * const 0x061f68e8) line 92 +
27 bytes
nsAttrAndChildArray::Clear(nsAttrAndChildArray * const 0x0607baa0) line 621 + 6
bytes
nsAttrAndChildArray::~nsAttrAndChildArray(nsAttrAndChildArray * const
0x0607baa0) line 126

Comment 7

13 years ago

*** This bug has been marked as a duplicate of 237736 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
Crash Signature: [@ PL_DHashTableRawRemove ]
You need to log in before you can comment on or make changes to this bug.