Dump URLs to file on crash

RESOLVED DUPLICATE of bug 36810

Status

()

Firefox
Bookmarks & History
--
enhancement
RESOLVED DUPLICATE of bug 36810
13 years ago
9 years ago

People

(Reporter: nickhbo, Assigned: Ben Goodger (use ben at mozilla dot org for email))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0

Recently FireFox has been freezing up on me whenever I have 10-12 windows open
with a few tags in each window. This is a real pain when I have links I'm
working with scattered across the browser windows and I can't even get to them
so I can copy them. I can't reproduce this as I please, it just happens after a
while. 

Since there's no definite problem I can point out to fix I'm requesting that
when the browser crashes all the URLs be dumped to a file in the profile folder
or something. I once had to do a full memory dump of FireFox.exe to dig out some
URLs I had spent a good half an hour looking for on Google so I know the URLs
are in memory while the crash happens.

Having the URLs dumped to a file at least lets me go and get my URLs back so I
can bookmark them or get back at them if need be. I think this would be a great
feature to have, but of course I'm biased, and I don't think it would be that
hard to implement.

Reproducible: Couldn't Reproduce

Updated

13 years ago
Severity: normal → enhancement
Summary: Feature Request: Dump URLs to file on crash. → Dump URLs to file on crash

Comment 1

13 years ago

*** This bug has been marked as a duplicate of 36810 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE

Updated

9 years ago
Component: History → Bookmarks & History
QA Contact: mozilla → bookmarks
You need to log in before you can comment on or make changes to this bug.