Print options dialog gets hidden behind main mail window

RESOLVED WORKSFORME

Status

RESOLVED WORKSFORME
14 years ago
14 years ago

People

(Reporter: BlindWolf8, Assigned: mscott)

Tracking

x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.6) Gecko/20050223 Firefox/1.0.1 (ax)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.6) Gecko/20050223 Firefox/1.0.1 (ax)

When I go to print a message (by clicking on the down arrow next to the Print
button on the toolbar and then clicking "Print...") the "Status: Printing"
dialog comes up for a second (which, IMHO, shouldn't come up until after you
select printing options, which leads to my next point) and it seems as if
nothing happens, BUT the print options dialog box sometimes spawns behind the
main mail window unknowingly, leading to confusion.  I have to minimize the
program to see it.

Reproducible: Sometimes

Steps to Reproduce:
1. Print button on toolbar -> Print...
2. Wait for a print options dialog box to come up
3. If none does, minimize Thunderbird
Actual Results:  
No print options dialog box comes up

Expected Results:  
The print options dialog box should have come up

Extensions installed:
*Minimize to Tray
*Compact Menu
(Reporter)

Updated

14 years ago
Summary: Print dialog gets hidden behind main mail window → Print options dialog gets hidden behind main mail window
Version: unspecified → 1.0

Comment 1

14 years ago
the "Status: Printing" dialog is not actually about sending the mail to the
printer but about generating the "image" which is send to the printer.

i cannot reproduce the bug. maybe you click on the thunderbird window between
step 1 and 2 and that's why the print options dialog is not focused?
(Reporter)

Comment 2

14 years ago
No, just tried printing the response to this bug and the options dialog came up
behind the main mail window (had to minimize the main mail window).

Comment 3

14 years ago
I cannot reproduce this bug, i've tried:
1.0 (de-DE)
1.0.2 (en-US)
2005-03-21-05-trunk (en-US)

on:
Windows 2000 SP4
Windows XP SP2

Reporter: could you please try to reproduce the bug:
a) with a new profile (without the extensions)
b) with a new installation of Thunderbird
(Reporter)

Comment 4

14 years ago
As a side note, this only seems to happen when I maximize Thunderbird, and I try
clicking on menus and such and I get a long pause (maybe 5-10 seconds) before
anything happens.
(Reporter)

Comment 5

14 years ago
This cannot be reproduced with TBird 1.0.2 with a fresh profile or my own
profile.  Please see previous post for more info.

Comment 6

14 years ago
reporter: can you please mark this bug as WFM
(Reporter)

Updated

14 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.