page with complex embedded tables and javascript with style "display:none" are randomly displayed wrong

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
14 years ago
12 years ago

People

(Reporter: cjames53, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.6) Gecko/20050223 Firefox/1.0.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.6) Gecko/20050223 Firefox/1.0.1

To see the bug, reload the page repeatedly.  It will usually format
the page incorrectly on the fourth or fifth try.

This is a very complex form for entering chemical searches (minus a lot
of graphics and stuff that were removed so they wouldn't obscured the
issue).  At the top are six tabs, each of which should show a separate
part of form.  Each of the sections is itself complex.  The most complex are
the first two, the "Required" and "Prohibited" tabs -- they each contain a
three-level drop-down menu.

If the system is working right, you should be able to click on
"Required", then click on any "+" sign to drop down a category of
chemicals, then click on the next-level "+" sign to select particular
categories of chemicals.

Thanks for your help.

Reproducible: Sometimes

Steps to Reproduce:
1.Clear your browser's cache, etc.
2.Load the page
3.Click on the "reload" button repeatedly until it is displayed incorrectly.  It
usually takes anywhere from one to a dozen reloads.

Actual Results:  
Some of the drop-down menus, which should be hidden, are permanently shown --
that is, clicking on the tabs at the top and clicking on the "+" signs, won't
make them disappear.  They're shown in seemingly-random places on the screen. 
The display stays in this state untils you click "Reload" again, at which time
it may display correctly, or may randomly display some other chunk of the menus.

Expected Results:  
Format the display exactly the same way every time.

Well, I doubt many folks run into this bug, but I have to tell my users to use
Internet Explorer :-(
This is an automated message, with ID "auto-resolve01".

This bug has had no comments for a long time. Statistically, we have found that
bug reports that have not been confirmed by a second user after three months are
highly unlikely to be the source of a fix to the code.

While your input is very important to us, our resources are limited and so we
are asking for your help in focussing our efforts. If you can still reproduce
this problem in the latest version of the product (see below for how to obtain a
copy) or, for feature requests, if it's not present in the latest version and
you still believe we should implement it, please visit the URL of this bug
(given at the top of this mail) and add a comment to that effect, giving more
reproduction information if you have it.

If it is not a problem any longer, you need take no action. If this bug is not
changed in any way in the next two weeks, it will be automatically resolved.
Thank you for your help in this matter.

The latest beta releases can be obtained from:
Firefox:     http://www.mozilla.org/projects/firefox/
Thunderbird: http://www.mozilla.org/products/thunderbird/releases/1.5beta1.html
Seamonkey:   http://www.mozilla.org/projects/seamonkey/
(Reporter)

Comment 2

13 years ago
I updated to Firefox 1.0.7 and confirmed that this bug is still present.  The
behavior is identical: Random changes to the displayed page each time you hit
the Refresh button.  The original example that illustrates this bug is still on
my web site:

  http://www.moonviewscientific.com/firefox_bug/firefox_javascript_bug.htm

Load the page, and then hit Refresh.  You'll see that some of the menu items are
randomly placed outside of the enclosing tables.

Sorry to be a pest, but we're launching a major new service soon that will be
widely used by the scientific community, and without this bug fixed, we will
have to advise scientists to use IE.  Thanks!!

Craig
Assignee: bross2 → nobody
I can't reproduce using Firefox 2.0.0.3 on Windows XP SP 2 or Mac OS X 10.4.9. Can you reproduce this using Firefox 2.0.0.3 or later with a clean profile? 

http://kb.mozillazine.org/Profile_Manager
Whiteboard: CLOSEME - 04/15/07
Closing this bug as "works for me". If you're able to reproduce and willing to provide info in this bug (specifically, answer comment 3), please reopen.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → WORKSFORME
Whiteboard: CLOSEME - 04/15/07
You need to log in before you can comment on or make changes to this bug.