Startup errors/warnings in JavaScript console (trunk)

VERIFIED FIXED

Status

Thunderbird
General
VERIFIED FIXED
13 years ago
11 years ago

People

(Reporter: Mike Cowperthwaite, Assigned: whimboo)

Tracking

(Blocks: 2 bugs, {regression, verified1.8.1.3})

Trunk
regression, verified1.8.1.3
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments, 2 obsolete attachments)

(Reporter)

Description

13 years ago
TB 1.0+0222, Win2K


Error: [Exception... "Component returned failure code: 0x8000ffff 
(NS_ERROR_UNEXPECTED) [nsIPrefBranch.getCharPref]"  nsresult: "0x8000ffff 
(NS_ERROR_UNEXPECTED)"  location: "JS frame :: file:///C:/Moz/TB/components/
nsDefaultCLH.js :: clh_handle :: line 81"  data: no]
Source File: file:///C:/Moz/TB/components/nsDefaultCLH.js
Line: 81

Error: redeclaration of const kMailToLength
Source File: chrome://communicator/content/nsContextMenu.js
Line: 12

Error: redeclaration of const SAVETYPE_COMPLETE_PAGE
Source File: chrome://communicator/content/contentAreaUtils.js
Line: 245


These errors have been appearing for a while -- see bug 279657, which was filed 
under the Mac.
If they have any side effects, I dunno what those could be.
(Reporter)

Comment 1

13 years ago
In TB 1.0+0327, the first (and presumably most serious) of the listed errors no 
longer appears.

Comment 2

13 years ago
gandalf accidentally removed a bunch of core files for Thunderbird over the weekend.
Assignee: mscott → gandalf
Severity: normal → blocker
Keywords: regression
Scott: It's not my fault. It has nothing to do with my patch.
Assignee: gandalf → mscott

Comment 4

13 years ago
whoops I read this bug report wrong. 
Severity: blocker → normal
(Assignee)

Comment 5

13 years ago
All errors are gone now. Only a remaining js strict warning still appears:

Warning: reference to undefined property defaultServer.msgFolder
Source File: chrome://messenger/content/msgMail3PaneWindow.js
Line: 920
Summary: Startup errors in JavaScript console (trunk) → Startup errors/warnings in JavaScript console (trunk)
(Reporter)

Comment 6

13 years ago
(In reply to comment #5)
> All errors are gone now. Only a remaining js strict warning still appears:
> 
> Warning: reference to undefined property defaultServer.msgFolder
> Source File: chrome://messenger/content/msgMail3PaneWindow.js
> Line: 920

I'm not even seeing that one! (0725, Win2K)  Maybe it's from an extension?
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → WORKSFORME
(Assignee)

Comment 7

13 years ago
Mike, I still see this strict warning with a todays cvs build. I've no
extensions installed within my profile. I downloaded an official nightly build
and found some more warnings. These are still part of mail source:

Warning: variable displayName hides argument
Source File: chrome://messenger/content/msgHdrViewOverlay.js
Line: 420, Column: 10
Source Code:
      var displayName = displayName.replace(/ +/g, " ");

Warning: variable emailAddress hides argument
Source File: chrome://messenger/content/msgHdrViewOverlay.js
Line: 944, Column: 6
Source Code:
  var emailAddress = addressNode.getTextAttribute("emailAddress");

Warning: variable folder hides argument
Source File: chrome://messenger/content/mailWindowOverlay.js
Line: 2085, Column: 14
Source Code:
          var folder = GetLoadedMsgFolder();

Warning: reference to undefined property defaultServer.msgFolder
Source File: chrome://messenger/content/msgMail3PaneWindow.js
Line: 920

Reopening until we solved the remaining strict warnings.
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
(Reporter)

Comment 8

13 years ago
With 0803, this one is back:
Error: Unknown namespace prefix 'html'.  Ruleset ignored due to bad selector.
Source File: chrome://messenger/skin/messageBody.css
Line: 55

But that's the only one I'm seeing.  (Win2K)
(Assignee)

Updated

13 years ago
Blocks: 303545
(Assignee)

Comment 9

13 years ago
Created attachment 195646 [details] [diff] [review]
Fix for all js warnings
Assignee: mscott → hskupin
Status: REOPENED → ASSIGNED
Attachment #195646 - Flags: review?(mscott)
(Assignee)

Comment 10

13 years ago
Created attachment 195656 [details] [diff] [review]
Patch without msgMail3PaneWindow.js changes

The warning within msgMail3PaneWindow.js will be fixed by the fix on bug
270743.
Attachment #195646 - Attachment is obsolete: true
Attachment #195656 - Flags: review?(mscott)
(Assignee)

Updated

13 years ago
Attachment #195646 - Flags: review?(mscott)

Updated

13 years ago
Attachment #195656 - Flags: review?(mscott) → review+
(Assignee)

Comment 11

13 years ago
Comment on attachment 195656 [details] [diff] [review]
Patch without msgMail3PaneWindow.js changes

The patch can be safely applied without any reported error to the 1.8 branch
version:

> patching file mail/base/content/msgHdrViewOverlay.js
> patching file mail/base/content/mailWindowOverlay.js
Attachment #195656 - Flags: approval1.8b5?

Comment 12

13 years ago
Comment on attachment 195656 [details] [diff] [review]
Patch without msgMail3PaneWindow.js changes

please don't nominate th8ings like JS warning as blockers for the branch. The
trunk is fine for these bugs.
Attachment #195656 - Flags: approval1.8b5? → approval1.8b5-
(Assignee)

Updated

13 years ago
Whiteboard: [checkin needed]
(Assignee)

Updated

13 years ago
Attachment #195656 - Flags: superreview?(mscott)
(Assignee)

Comment 13

13 years ago
These are small changes of js code. Do we really need sr=? If not, this patch
could be checked-in on the trunk.
(Assignee)

Comment 14

13 years ago
Scott, can you give an advice how to handle the remaining steps to get my patch checked-in?

Comment 15

13 years ago
Comment on attachment 195656 [details] [diff] [review]
Patch without msgMail3PaneWindow.js changes

sr'ing a patch i already reviewed.
Attachment #195656 - Flags: superreview?(mscott) → superreview+
(Assignee)

Comment 16

13 years ago
2005-11-09 13:40	timeless%mozdev.org 	mozilla/ mail/ base/ content/ mailWindowOverlay.js 	1.105 	3/2

2005-11-09 13:40	timeless%mozdev.org 	mozilla/ mail/ base/ content/ msgHdrViewOverlay.js 	1.62 	4/4
Status: ASSIGNED → RESOLVED
Last Resolved: 13 years ago13 years ago
Resolution: --- → FIXED
Whiteboard: [checkin needed]
Blocks: 285596
(Assignee)

Comment 17

11 years ago
Attachment 195656 [details] [diff] was never checked into 1.8 branch. The js warnings are still present in current builds. The code has changed a bit. It has to be adapted. I don't have any chance to do it for the next days. Seems that's also too late for Thunderbird 2. :(

Warning: variable displayName hides argument
Source File: chrome://messenger/content/msgHdrViewOverlay.js
Line: 409, Column: 10
Source Code:
      var displayName = displayName.replace(/ +/g, " ");

Warning: variable emailAddress hides argument
Source File: chrome://messenger/content/msgHdrViewOverlay.js
Line: 899, Column: 6
Source Code:
  var emailAddress = addressNode.getAttribute("emailAddress");
(Assignee)

Comment 18

11 years ago
Created attachment 258403 [details] [diff] [review]
Remove startup warnings for 1_8_branch
Attachment #258403 - Flags: review?
Attachment #258403 - Flags: approval-thunderbird2?
(Assignee)

Comment 19

11 years ago
Created attachment 258404 [details] [diff] [review]
[checked into the branch] Remove startup warnings for 1_8_branch

Scott, is it quiet possible to get this simple fix into Thunderbird 2? It will remove all the clutter from the Error Console when starting Thunderbird.
Attachment #258404 - Flags: review?(mscott)
Attachment #258404 - Flags: approval-thunderbird2?
(Assignee)

Updated

11 years ago
Attachment #258403 - Attachment is obsolete: true
Attachment #258403 - Flags: review?
Attachment #258403 - Flags: approval-thunderbird2?

Comment 20

11 years ago
Comment on attachment 258404 [details] [diff] [review]
[checked into the branch] Remove startup warnings for 1_8_branch

Please don't expect us to usually take JS warning fixes this late in the release cycle. I don't want to set a precedent. :)

This has been baking for over a year and we haven't tagged yet so I'm going to put it in.
Attachment #258404 - Flags: review?(mscott)
Attachment #258404 - Flags: review+
Attachment #258404 - Flags: approval-thunderbird2?
Attachment #258404 - Flags: approval-thunderbird2+

Updated

11 years ago
Attachment #258404 - Attachment description: Remove startup warnings for 1_8_branch → [checked into the branch] Remove startup warnings for 1_8_branch
(Assignee)

Updated

11 years ago
Status: RESOLVED → VERIFIED
Keywords: verified1.8.1.3
(Assignee)

Comment 21

11 years ago
No, I don't expect. ;) Thank you Scott.
You need to log in before you can comment on or make changes to this bug.