[RFE] Identity settings (From/Reply-To) specific to addressee

RESOLVED DUPLICATE of bug 269491

Status

Thunderbird
General
--
enhancement
RESOLVED DUPLICATE of bug 269491
13 years ago
11 years ago

People

(Reporter: Robert Rothenberg, Assigned: Scott MacGregor)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0

I have multiple identities and E-mail accounts, and when I send E-mail to
certain people, I do so from specific accounts (e.g. certain From: and/or
Reply-To addresses, etc.).  It would be nice to have an option (settable for
each account) so that when I send E-mail for Thunderbird to recognize addressees
and change the From/Reply-To address accordingly.

This could be implemented using a hashing algorithm on the E-mail address to see
if it's been sent to from a specific account.

There are some potential problems that Thunderbird would need to alert the user.
If an addressee was sent to from multiple accounts, then it will need to ask
which one. (There should also be a way for users to 'edit' this list so if a
conflict occurs it can be corrected, rather than exist forever.)

Another potential conflict is when one sends a message to two addressees that
are normally corresponded to from different accounts.  Again, Thunderbird should
ask for advice.

To keep it simple, options should be account specific.  jdoe@xyz.com has always
been sent mail from the msmith@abc.net account, so whenever a message is sent to
jdoe@xyz.com, it is sent from the msmith@abc.net account with that account's
settings.  Thunderbird should recognize this as soon as jdoe@xyz.com is put in
the To/Cc/Bcc field.  And likewise it should point out conflicts as soon as it
recognizes them.

Of course the user will have the ability to override settings on a per-mail
basis.  (I would be wary of confirmation dialogs that easily allow users to make
new settings permanent, because often users blindly hit ok without reading
confirmation dialogs, as they get in the way of a program's usability.)

The advantage of such a feature is that it allows the software to adapt
automatically to the user's behavior so that the user does not have to remember
to do the same repetative tasks.


Reproducible: Always

Steps to Reproduce:
N/A
This is an automated message, with ID "auto-resolve01".

This bug has had no comments for a long time. Statistically, we have found that
bug reports that have not been confirmed by a second user after three months are
highly unlikely to be the source of a fix to the code.

While your input is very important to us, our resources are limited and so we
are asking for your help in focussing our efforts. If you can still reproduce
this problem in the latest version of the product (see below for how to obtain a
copy) or, for feature requests, if it's not present in the latest version and
you still believe we should implement it, please visit the URL of this bug
(given at the top of this mail) and add a comment to that effect, giving more
reproduction information if you have it.

If it is not a problem any longer, you need take no action. If this bug is not
changed in any way in the next two weeks, it will be automatically resolved.
Thank you for your help in this matter.

The latest beta releases can be obtained from:
Firefox:     http://www.mozilla.org/projects/firefox/
Thunderbird: http://www.mozilla.org/products/thunderbird/releases/1.5beta1.html
Seamonkey:   http://www.mozilla.org/projects/seamonkey/
(Reporter)

Comment 2

12 years ago
This is a request for an enhancement. As far as I can tell, the feature has not
been added, nor do I know of a plug-in that provides this feature.

Please keep this open.
(Reporter)

Comment 3

12 years ago
Note that the "Correct Identity" plugin for Thunderbird may be a fix for this issue. I'll need to investigate it further.
(Reporter)

Updated

12 years ago
Summary: [WISHLIST] Identity settings (From/Reply-To) specific to addressee → [RFE] Identity settings (From/Reply-To) specific to addressee

Comment 4

12 years ago
(In reply to comment #3)
> Note that the "Correct Identity" plugin for Thunderbird may be a fix for this
> issue. I'll need to investigate it further.
> 

Robert, might you consider this a dupe of Bug #264770? I started searching tonight, as this RFE just came to me. I use multiple identities with the same account to change my signature (my wife doesn't need to read my company information, and neither does my brother - my partner). I thought it would be handy to just have SeaMonkey Mail know when I am replying or sending to either of them to just switch idents automagically.

Lewis

Comment 5

11 years ago

*** This bug has been marked as a duplicate of 269491 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.