wrong filtering in create-guided causes problems

RESOLVED FIXED in Bugzilla 2.20

Status

()

Bugzilla
Creating/Changing Bugs
--
minor
RESOLVED FIXED
13 years ago
13 years ago

People

(Reporter: GavinS, Assigned: GavinS)

Tracking

2.19.2
Bugzilla 2.20
Bug Flags:
approval +

Details

Attachments

(1 attachment)

(Assignee)

Description

13 years ago
patch soon...
(Assignee)

Comment 1

13 years ago
Created attachment 175625 [details] [diff] [review]
fix filtering on product passed to duplicates.cgi from create-guided

If a product contained, say, a semi-colon, then the duplicates.cgi IFRAME would
give an error saying 'bad product', because we used the wrong filtering, I
think.
Attachment #175625 - Flags: review?
Comment on attachment 175625 [details] [diff] [review]
fix filtering on product passed to duplicates.cgi from create-guided

Tested; works.
The BLOCK is necessary to keep the "=" unFILTERed, right?
Attachment #175625 - Flags: review? → review+
Flags: approval?
(Assignee)

Comment 3

13 years ago
(In reply to comment #2)
> The BLOCK is necessary to keep the "=" unFILTERed, right?
Yes. 
Flags: approval? → approval+
Target Milestone: --- → Bugzilla 2.20

Comment 4

13 years ago
Checking in template/en/default/bug/create/create-guided.html.tmpl;
/cvsroot/mozilla/webtools/bugzilla/template/en/default/bug/create/create-
guided.html.tmpl,v  <--  create-guided.html.tmpl
new revision: 1.24; previous revision: 1.23
done
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.