form select scrollbar stops working

RESOLVED FIXED

Status

()

Core
Layout: Form Controls
--
major
RESOLVED FIXED
14 years ago
13 years ago

People

(Reporter: Andrew Schultz, Assigned: Kyle Yuan)

Tracking

({regression, testcase})

Trunk
x86
All
regression, testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

14 years ago
With linux trunk build 2005022505 , the scrollbars on the form SELECTs on the
bugzilla query page (component, version, etc) stop working after selecting a
product.  The SELECT can still be scrolled with the mouse wheel, but the
scrollbar thumb doesn't move.

This regressed between linux trunk 2005022305 and 2005022405.  bug 268513 looks
like the most likely candidate in that window.
(Reporter)

Comment 1

14 years ago
Created attachment 175631 [details]
testcase

with linux trunk 2005022505, the scrollbar is dead once the page loads
(Reporter)

Updated

14 years ago
Flags: blocking1.8b2?
Summary: form select scrollbar stops working → form select scrollbar stops working
(Reporter)

Comment 2

14 years ago
in a debug build, I get this when hovering over the scrollbar:
###!!! ASSERTION: moved hover/active between nodes in different documents:
'!anc1->GetDocument()', file nsEventStateManager.cpp, line 3730

Comment 3

14 years ago
seeing bug on Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.8b2) Gecko/20050226
Build Id: 2005022600
wfm Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.8b2) Gecko/20050223 
Build Id: 2005022305

I don´t see this bug if I load a local copy of the attached testcase, loading it
from here shows the bug, as seen on the query page.
OS: Linux → All

Comment 4

14 years ago
Backing out bug 268513 fixes this bug.
Assignee: nobody → kyle.yuan
Blocks: 268513

Comment 5

14 years ago
*** Bug 284047 has been marked as a duplicate of this bug. ***

Comment 6

14 years ago
(In reply to comment #4)
> Backing out bug 268513 fixes this bug.

The backing out was done. Should this one be marked as "fixed"?
Yes.
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → FIXED

Updated

13 years ago
Flags: blocking1.8b2?
You need to log in before you can comment on or make changes to this bug.