Spawned Javascript window crashes Fx [@ nsFrame::GetContentForEvent ]

RESOLVED WORKSFORME

Status

()

Core
Layout
--
critical
RESOLVED WORKSFORME
13 years ago
7 years ago

People

(Reporter: Andreas, Unassigned)

Tracking

({crash})

Trunk
x86
Windows 2000
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(crash signature, URL)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.6) Gecko/20050223 Firefox/1.0.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.6) Gecko/20050223 Firefox/1.0.1

When trying to access Nikon's Live Manuals function which uses java Firefox
1.0.1 crashes randomly.
By random i mean that it is just a matter of time before it does crash , it
allways crash.


Reproducible: Always

Steps to Reproduce:
1.Go to http://www.nikonusa.com/template.php?cat=1&grp=2&productNr=25214
2.Paste following into the URL bar and hit enter:
javascript:openVSimWindow('NK018', '', '', '', '','Nikon D70 Digital
SLR','1','0');void(0); 
3.A new window or tab (depending on settings) will be started and load up Nikon
Live Manual for Nikon D70.
4. Select a few demos to run or click down the window and Firefox will
eventually crash

Actual Results:  
Firefox crashed and was not visible in task manager

Expected Results:  
Not crash :)

Comment 1

13 years ago
Andreas: Could you provide Talkback incident ID of your crash?
Severity: major → critical
Keywords: crash
Summary: Spawned Javascript window crashes FF 1.0.1 → Spawned Javascript window crashes FF 1.0.1
(Reporter)

Comment 2

13 years ago
Adam: Thanks for the walk through on this :)

Here is the talk back ID: TB4002367K
(Reporter)

Comment 3

13 years ago
(In reply to comment #2)
> Adam: Thanks for the walk through on this :)
> 
> Here is the talk back ID: TB4002367K

Forgott to mention that the TB ID is for the latest trunk build.

Comment 4

13 years ago
TB4002367K:
nsFrame::GetContentForEvent 
[c:/builds/tinderbox/Fx-Trunk/WINNT_5.0_Depend/mozilla/layout/generic/nsFrame.cpp,
line 938]
nsViewManager::HandleEvent 
[c:/builds/tinderbox/Fx-Trunk/WINNT_5.0_Depend/mozilla/view/src/nsViewManager.cpp,
line 2490]
nsViewManager::DispatchEvent 
[c:/builds/tinderbox/Fx-Trunk/WINNT_5.0_Depend/mozilla/view/src/nsViewManager.cpp,
line 2212]
HandleEvent 
[c:/builds/tinderbox/Fx-Trunk/WINNT_5.0_Depend/mozilla/view/src/nsView.cpp, line
174]
nsWindow::DispatchEvent 
[c:/builds/tinderbox/Fx-Trunk/WINNT_5.0_Depend/mozilla/widget/src/windows/nsWindow.cpp,
line 1127]
nsWindow::DispatchMouseEvent 
[c:/builds/tinderbox/Fx-Trunk/WINNT_5.0_Depend/mozilla/widget/src/windows/nsWindow.cpp,
line 5490]
ChildWindow::DispatchMouseEvent 
[c:/builds/tinderbox/Fx-Trunk/WINNT_5.0_Depend/mozilla/widget/src/windows/nsWindow.cpp,
line 5747]
nsWindow::WindowProc 
[c:/builds/tinderbox/Fx-Trunk/WINNT_5.0_Depend/mozilla/widget/src/windows/nsWindow.cpp,
line 1419]
USER32.dll + 0x2a420 (0x77e3a420)
USER32.dll + 0x4605 (0x77e14605)
USER32.dll + 0xa7ba (0x77e1a7ba)
nsAppStartup::Run 
[c:/builds/tinderbox/Fx-Trunk/WINNT_5.0_Depend/mozilla/toolkit/components/startup/src/nsAppStartup.cpp,
line 145]
main 
[c:/builds/tinderbox/Fx-Trunk/WINNT_5.0_Depend/mozilla/browser/app/nsBrowserApp.cpp,
line 60]
KERNEL32.DLL + 0x2893d (0x7c59893d)

-> Core / Layout
Assignee: firefox → nobody
Component: General → Layout
Product: Firefox → Core
QA Contact: general → layout
Summary: Spawned Javascript window crashes FF 1.0.1 → Spawned Javascript window crashes Fx [@ nsFrame::GetContentForEvent ]
Version: unspecified → Trunk
(Reporter)

Comment 5

13 years ago
Tested this on Trunk Build March 5

A problem i noticed was that Firefox wouldn't release memory and steadliy as you
click on the new parts of the program.
When loading a new part of the program it makes sense , but when go back to the
same part later on (which should already be in memory) it eats up just as much
memory again as when initializing in the first place.
Firefox crashed , but the talk back agent didn't catch it so i can't send a new
ID for this.
Easy to see this behaviour, click this link and then watch the memory usage
until FF crashes.

http://www.nikonusa.com/livemanuals/NK018/pkg/simulation/sim.html?prodPath=NK018&pid=&prodName=Nikon%20D70%20Digital%20SLR&applicationName=&scenarioName=&scenarioNumber=&fb=1&ss=0

This is an automated message, with ID "auto-resolve01".

This bug has had no comments for a long time. Statistically, we have found that
bug reports that have not been confirmed by a second user after three months are
highly unlikely to be the source of a fix to the code.

While your input is very important to us, our resources are limited and so we
are asking for your help in focussing our efforts. If you can still reproduce
this problem in the latest version of the product (see below for how to obtain a
copy) or, for feature requests, if it's not present in the latest version and
you still believe we should implement it, please visit the URL of this bug
(given at the top of this mail) and add a comment to that effect, giving more
reproduction information if you have it.

If it is not a problem any longer, you need take no action. If this bug is not
changed in any way in the next two weeks, it will be automatically resolved.
Thank you for your help in this matter.

The latest beta releases can be obtained from:
Firefox:     http://www.mozilla.org/projects/firefox/
Thunderbird: http://www.mozilla.org/products/thunderbird/releases/1.5beta1.html
Seamonkey:   http://www.mozilla.org/projects/seamonkey/

Comment 7

12 years ago
As this bug has had no comments for over a year and got no response to the auto-resolve message, and I couldn't reproduce, marking it worksforme. If it's still a problem, please reopen.

Comment 8

12 years ago
Oops, actually marking it worksforme this time...
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → WORKSFORME
(Assignee)

Updated

7 years ago
Crash Signature: [@ nsFrame::GetContentForEvent ]
You need to log in before you can comment on or make changes to this bug.