Windows uninstall fails if disk is FULL (no error is displayed)

RESOLVED WORKSFORME

Status

()

Firefox
Installer
RESOLVED WORKSFORME
13 years ago
8 years ago

People

(Reporter: Jari Aalto, Unassigned)

Tracking

1.5.0.x Branch
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0; en) Opera 8.00
Build Identifier: Firefox 1.0PR

Trying to uninstall Firefox on a system where disk is full from
Start => Control Panel => Add/Remove programs => Firefox [Change | remove]
fails without any error message.

The only indication is dialofg message (see attached copy) and then nothing.

Reproducible: Always

Steps to Reproduce:
1. Fill in disk
2. Try uninstall from control panel
3.

Actual Results:  
No error messages. No uninstall.

Expected Results:  
Uninstaller shoudl check for available disk space before trying to uncompress 
the installer (if that is what it is doing) and running it. There should be
a note that user must make more room before uninstaller can be run.
(Reporter)

Comment 1

13 years ago
Created attachment 175644 [details]
Messsages that appear during uninstall (no errors)

Nothing happens after these dialogs on DISK full case

Updated

13 years ago
Assignee: bugs → nobody
QA Contact: bugzilla → installer
Version: unspecified → 1.5.0.x Branch
Probably related to bug 266591, but may not the same bug since this concerns uninstall.
This bug was reported on Firefox 2.x or older, which is no longer supported and will not be receiving any more updates. I strongly suggest that you update to Firefox 3.6.3 or later, update your plugins (flash, adobe, etc.), and retest in a new profile. If you still see the issue with the updated Firefox, please post here. Otherwise, please close as RESOLVED > WORKSFORME
http://www.mozilla.com
http://support.mozilla.com/kb/Managing+profiles
http://support.mozilla.com/kb/Safe+mode
(Reporter)

Comment 4

8 years ago
> "I strongly suggest that you update to Firefox 3.6.3 ...If you still see the issue with the updated Firefox, please post here"

Here were the test steps how the developer team arrange the environment and what steps are needed to see if this problem is not yet tackled in latest Firefox installer

Reproducible: Always

Steps to Reproduce:
1. Fill in disk
2. Try uninstall from control panel

Actual Results:  
No error messages. No uninstall.
So, you still see this with 3.6.3?
No reply, INCOMPLETE. Please retest with Firefox 3.6.x or later and a new profile (http://support.mozilla.com/kb/Managing+profiles). If you continue to see this issue with the newest firefox and a new profile, then please comment on this bug.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → INCOMPLETE
(Reporter)

Comment 7

8 years ago
"if you continue to see this issue..."

I would assume that the responsibility of verifying the software to work is on the developers. There is clear test case to follow which does not depends on any specific settings.

I've reported the bug, so I feel I have brought something to your attention in best of my intentions to help. Five years (!) has passed since and there is such disk available any more here.

If you're asking to participate to your development cycle, there I do not unfortunately have the resources.
Resolution: INCOMPLETE → FIXED

Updated

8 years ago
Resolution: FIXED → WORKSFORME
You need to log in before you can comment on or make changes to this bug.