Scrolling in dropdown boxes using arrow keys results in weird scrolling and incorrect loop to top of list

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
14 years ago
2 years ago

People

(Reporter: bram, Unassigned)

Tracking

({regression})

Trunk
x86
Windows XP
regression
Points:
---
Bug Flags:
blocking1.8b5 -

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b2) Gecko/20050225 Firefox/1.0+
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b2) Gecko/20050225 Firefox/1.0+

Dropdown comboboxes in the options interface (couldn't find any other to test
yet) behave strangely when opening the dropdown, placing the mouse over the
dropped down list and scrolling using arrow keys on keyboard. 

Reproducible: Always

Steps to Reproduce:
1. Open Tools -> Options -> Content
2. Click on the dropdown opening button for the Default Font selection
3. Hover the mouse over the list
4. Press the down arrow on your keyboard until you reach the bottom of the
visible items
5. Keep pressing down and try to figure out what happens

Actual Results:  
It scrolls down for one item at most and then the highlight disappears. Pressing
down again makes the first item in the list selected.

Expected Results:  
Scroll the list while keeping the bottom item highlighted just like when you
don't hover your mouse cursor over the list.

Attached to this bug there is a movie. As soon as I have opened the dropdown I
press the down arrow a few times.
(Reporter)

Comment 1

14 years ago
Created attachment 175651 [details]
Screen capture showing strange scrolling

Comment 2

14 years ago
dup of bug 283788?

Updated

14 years ago
Blocks: 268513

Comment 3

14 years ago
what may have caused this - the fix for bug 268513 - was backed out so builds from 
today (28th) or later should be good - can you try that?
(Reporter)

Comment 4

14 years ago
Tried the 2005-02-28 09:24 Beast build, bug still exists.
So this probably isn't blocking bug 268513.

Updated

14 years ago
No longer blocks: 268513

Updated

14 years ago
Assignee: jag → bugs
Component: XP Toolkit/Widgets → Preferences
Product: Core → Firefox
QA Contact: jrgmorrison → mconnor
Flags: blocking-aviary1.1?

Comment 5

14 years ago
Created attachment 179800 [details]
testcase

Comment 6

14 years ago
For me it just doesn't scroll visible items into view when navigating with
keyboard. Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b2)
Gecko/20050405 Firefox/1.0+

With Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b2) Gecko/20050326 I
get the same as reporter using Classic theme, but everything works fine in Modern.

This is regression; Firefox 1.0 doesn't have this problem.
Keywords: regression

Comment 7

14 years ago
>For me it just doesn't scroll visible items into view when navigating with
keyboard.
Not sure on this one.

It's definitely a core issue, although I've probably picked the wrong component.
Assignee: bugs → jag
Status: UNCONFIRMED → NEW
Component: Preferences → XP Toolkit/Widgets
Ever confirmed: true
Product: Firefox → Core
QA Contact: mconnor → jrgmorrison

Comment 8

13 years ago
transferring nomination to 1.8b4. If we don't get it there, we don't get it for 1.1
Flags: blocking-aviary1.1? → blocking1.8b4?

Updated

13 years ago
Flags: blocking1.8b4? → blocking1.8b4-

Updated

10 years ago
Assignee: jag → nobody
Hi Bram,

I have tested this issue on the latest Firefox (45.0.1) release and latest Nightly (48.0a1) build and I could not reproduce it. I have also tested this on Firefox version 1.5.0.9 and I was able to reproduce it. I think this bug was already fixed. 
On Nightly with e10s enabled, the dropdown list does not work, it seems that this is a different bug related to e10s. I will log another bug related to this issue.

Considering the fact that I cannot reproduce this a I will mark this as Resolved-Worksforme. If anyone can still reproduce it, feel free to reopen the issue and provide more information.

Thanks,
Cosmin.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.