Closed Bug 283852 Opened 20 years ago Closed 15 years ago

Crashed while printing (Quartz image code?)

Categories

(Core Graveyard :: GFX: Mac, defect)

PowerPC
macOS
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED WORKSFORME

People

(Reporter: sfraser_bugs, Assigned: jhpedemonte)

Details

(Keywords: crash, testcase)

Attachments

(2 files)

My 2/20 Camino build just crashed while printing:

Exception:  EXC_BAD_ACCESS (0x0001)
Codes:      KERN_INVALID_ADDRESS (0x0001) at 0x07f24000

Thread 0 Crashed:
0   com.apple.CoreGraphics         	0x93641cd8 decode_data + 0x430
1   com.apple.CoreGraphics         	0x9362f2dc img_decode_read + 0x404
2   com.apple.CoreGraphics         	0x93625e58 img_alphamerge_read + 0x1d0
3   com.apple.CoreGraphics         	0x9370eb64 CGSImageStreamRead + 0x154
4   libPDFRIP.A.dylib              	0x91b22cf4 getMaskedImage + 0xe4
5   libPDFRIP.A.dylib              	0x91b23104 imageRefEmitDefinition + 0xb4
6   libPDFRIP.A.dylib              	0x91b213ac PDFImageEmitDefinition + 0x34
7   libPDFRIP.A.dylib              	0x91b22024 emitImageDefinition + 0x18
8   com.apple.CoreFoundation       	0x90190f54 CFSetApplyFunction + 0xf8
9   libPDFRIP.A.dylib              	0x91b164f4 PDFImageSetEmitDefinitions + 0x50
10  libPDFRIP.A.dylib              	0x91b152d0 PDFDocumentEndPage + 0xa8
11  libPDFRIP.A.dylib              	0x91b15214 pdf_EndPage + 0x20
12  libConverter.dylib             	0x882a3768 Notify(CVBackEnd const*,
CVSessionInfo const*, void*, CVEvent) + 0x2ac
13  libConverter.dylib             	0x882aaa14 BackEndNotify(CVBackEnd const*,
CVSessionInfo const*, void*, CVEvent) + 0x118
14  ...e.print.framework.PrintCore 	0x916fe98c PJCEndPage(OpaquePMPrintSession*)
+ 0x40
15  ...e.print.framework.PrintCore 	0x916fe900 PMSessionEndPageNoDialog + 0x58
16  ...apple.print.framework.Print 	0x91906fa4 PMSessionEndPage + 0x18
17  org.mozilla.navigator          	0x0015d2fc nsDeviceContextSpecX::EndPage() +
0x1c
18  org.mozilla.navigator          	0x0015af04 nsDeviceContextMac::EndPage() + 0x54
19  org.mozilla.navigator          	0x00527818
nsSimplePageSequenceFrame::DoPageEnd(nsPresContext*) + 0x40
20  org.mozilla.navigator          	0x0045525c
nsPrintEngine::PrintPage(nsPresContext*, nsIPrintSettings*, nsPrintObject*,
int&) + 0x540
21  org.mozilla.navigator          	0x00564c94
nsPagePrintTimer::Notify(nsITimer*) + 0x40
22  libxpcom_core.dylib            	0x018501a0 nsTimerImpl::Fire() + 0xc4
23  libxpcom_core.dylib            	0x018502ac handleTimerEvent(TimerEventType*)
+ 0x8c
24  libxpcom_core.dylib            	0x0184c45c PL_HandleEvent + 0x24
25  libxpcom_core.dylib            	0x0184c380 PL_ProcessPendingEvents + 0x80
26  com.apple.CoreFoundation       	0x90193ca8 __CFRunLoopDoSources0 + 0x1fc
27  com.apple.CoreFoundation       	0x90191560 __CFRunLoopRun + 0x1b0
28  com.apple.CoreFoundation       	0x90195e8c CFRunLoopRunSpecific + 0x148
29  com.apple.HIToolbox            	0x927d5f60 RunCurrentEventLoopInMode + 0xac
30  com.apple.HIToolbox            	0x927dc640 ReceiveNextEventCommon + 0xf4
31  com.apple.HIToolbox            	0x927fe6a0
BlockUntilNextEventMatchingListInMode + 0x60
32  com.apple.AppKit               	0x92dd2e44 _DPSNextEvent + 0x180
33  com.apple.AppKit               	0x92de98c8 -[NSApplication
nextEventMatchingMask:untilDate:inMode:dequeue:] + 0x74
34  com.apple.AppKit               	0x92dfdc30 -[NSApplication run] + 0x21c
35  com.apple.AppKit               	0x92eba2b8 NSApplicationMain + 0x1d0
36  org.mozilla.navigator          	0x0000aa88 _start + 0x17c
37  org.mozilla.navigator          	0x0000a908 start + 0x30
I have not been able to reproduce.  Do you get this crash every time you print
an image, or on a certain page?
This was on an orbitz travel confirmation page, so I can't easily to back and
try it.

Maybe try printing with transparent images, and with > 1 copy of the same image
on a page.
Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8b2) Gecko/20050418
Firefox/1.0+

Date/Time:  2005-04-19 13:27:42 +0100
OS Version: 10.2.6 (Build 6L60)
Host:	    tit002.local.

Command:    firefox-bin
PID:	    499

Exception:  EXC_BAD_ACCESS (0x0001)
Codes:	    KERN_INVALID_ADDRESS (0x0001) at 0x0435e000

I was at Bug 269623 "Open print preview or printing crashes Firefox 
[@ 0x03c5c4d5 @ nsGfxScrollFrame::Destroy]", and was surprised to find that
the URL given crashed on the Mac, seemingly between the first and the second
page. The stack trace looks very similar to this one, the crash occuring at 
http://lxr.mozilla.org/seamonkey/source/gfx/src/mac/nsDeviceContextSpecX.cpp#157


I downloaded a build a few days old and got the same crash, the Talkback ID
being TB5197916Z.

A fox: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; de-DE; rv:1.7.5)
Gecko/20041108 Firefox/1.0 did not crash.

See Bug 286176 "printing hangs"
I have added some fprintf( ); statements to my build, and the problem has
hidden itself.
Still can't reproduce, even with the testcase.  Do you get the crash if you do
"Save as PDF..." from the print dialog?  If you get the crash consistently,
could you try to reduce the testcase to see what specifically is causing the crash?
I have been testing only with Preview. I did restart between getting the crash and
not getting it.
Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8b2) Gecko/20050416
Firefox/1.0+

I get this crash on my build of 2005-04-16 (non debug), but not on 2005-04-19
(after 0300 approx) or today - both debug builds. I am uncertain if this is
an intermittent problem, one whose recipe has more steps than I have established,
something inside Apple's code or maybe something that has been fixed in the last
few hours; but I am tending to think that there is/was a problem inside Mozilla,
and I shall continue to look out.

I will most certainly provide a shorter testcase.
Attached file Short Testcase
Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8b2) Gecko/20050412
Firefox/1.0+

Crash might not occur with later versions - it might have been fixed
Ben, thanks for the testcase, but I still can't reproduce with it.  However, I
did try going to www.netscape.de, and that crashes for me consistently on builds
from before yesterday.  Build 2005-04-28-08 crashes when printing, but build
2005-04-28-20 is just fine.  Stack trace from crash is very similar to sfraser's
original post.
Product: Core → Core Graveyard
Keywords: testcase
No crash printing from Firefox trunk or Camino 1.6.8 on Mac.  I tested with both of Ben Fowler's testcases.
Status: NEW → RESOLVED
Closed: 15 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Creator:
Created:
Updated:
Size: