JavaScript options annoying

RESOLVED DUPLICATE of bug 283716

Status

()

Firefox
Preferences
--
major
RESOLVED DUPLICATE of bug 283716
13 years ago
12 years ago

People

(Reporter: Thomas Schade, Assigned: Ben Goodger (use ben at mozilla dot org for email))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8b2) Gecko/20050226 Firefox/1.0+ Mnenhy/0.7.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8b2) Gecko/20050226 Firefox/1.0+ Mnenhy/0.7.1

Since
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8b2) Gecko/20050225
Firefox/1.0+
the options for JavaScript have been reduced to a somehow restricted, pure Yes /
No. All it allows is:
[ ] Enable JavaScript
    [ ] but disable common annoyances

This really _is_ annoying as it restricts totally the user from setting his own
preferences, e.g. 
Allow scripts to:
[X] Change images
[ ] Disable or replace context menus

The actual dialogue even does not show what is seen as annooying by the developpers.

Reproducible: Always

Steps to Reproduce:
1. Just try to set an individual option for JavaScript
2.
3.

Actual Results:  
It's simply not longer possible to configure JavaScript options to the user's need.

Expected Results:  
Allow individual options for JavaScript as before.

*** This bug has been marked as a duplicate of 283716 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
sorry for bugspam, long-overdue mass reassign of ancient QA contact bugs,
filter on "beltznerLovesGoats" to get rid of this mass change
QA Contact: mconnor → preferences
You need to log in before you can comment on or make changes to this bug.